Kentico 8.2 Cannot Delete Content

Doug Roberts asked on December 21, 2016 23:17

Since we have upgraded to Kentico 8.2 we have found that we cannot delete content on our production server. When I click on a content item in the Pages module and select the Trash Can nothing happens. I do not get a popup with my delete options. I do not have an add blocker and I can delete content on my dev site that uses a direct database copy from my production server. There must be something missing on the production server. The call that is made when I press the delete is:…3%23%23%23SEP%23%23%23%23SEP%23%23false%23%23SEP%23%23true&_=1482358374413

The message returns a 404 not found error.

Any help you could provide would be greatly appreciated.

Recent Answers

Roman Hutnyk answered on December 22, 2016 08:39

Do you see any error in the event log?

Are you able to create/update pages?

Are you global admin? - if not you might not be authorized to delete.

Have you tried to delete from listing view?: click on the parent node -> click listing above the content tree -> navigate a page you want to delete -> select delete action -> submit.

1 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on December 22, 2016 16:56

A few things to check:

  • In 8.2 the way jQuery is handled is different so this could be conflicting with your current site. Reference 1 Reference 2
  • Did you resign your macros? This could cause a lot of UI problems.
  • Could be invalid HTML causing problems. In the past, I've worked with clients who had nested <form> tags within their markup. forms development doesn't allow for nested <form> tags so double check for this and other invalid HTML as well.
1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.