Kentico 12 - error message saving page content

Sebastian Hahn asked on November 28, 2018 17:37

Hello,

after the installation of Kentico 12 (MVC - DancingGoat) i'm getting the following error message if i click on the "save" button (Page Tab).

Message received from forbidden origin: http://localhost:8080.

Can anyone help?

Correct Answer

David te Kloese answered on November 29, 2018 14:31

Had the same issue some time ago and also used to have the MVC application on a different port number.

Fixed it by adding the port number to the Site domain name in Sites application!

4 votesVote for this answer Unmark Correct answer

Recent Answers


Brenden Kehren answered on November 28, 2018 18:06

Have you checked the Kentico event logs or the IIS event logs?

0 votesVote for this answer Mark as a Correct answer

Sebastian Hahn answered on November 28, 2018 18:16

Hi Brenden,

The Kentico event log is empty and the IIS event log contains no information.

0 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on November 29, 2018 11:21

Hi,
What were the settings set during the installation? Are you running the site from Visual studio (debug or built-in VS web server)? What are the domain and presentation URL settings for your site? I just tried installing the sample MVC Dancing Goat, left everything by default and it is working fine.

0 votesVote for this answer Mark as a Correct answer

Sebastian Hahn answered on November 29, 2018 13:35

Hi,

i have reinstalled the sample MVC Project (Quick Installation, localhost) and left everything by default as well.

The problem is still present on pages using the pagebuilder (e.g. home / Banner). If i make changes in the Content Tab, the problem does not occur.

0 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on November 29, 2018 13:39

Hi,
Are you running the site from Visual studio (debug or built-in VS web server)? What are the domain and presentation URL settings for your site?
What is the exact change? I tried several changes on the Home page, on the Page tab, everything works fine.

0 votesVote for this answer Mark as a Correct answer

Carsten Gerwing answered on November 29, 2018 14:39 (last edited on November 29, 2018 14:40)

0 votesVote for this answer Mark as a Correct answer

Sebastian Hahn answered on November 29, 2018 14:41

Hi David,

thanks. This was the solution.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.