HTML Minification with WebMarkupMin

Yoyo Bubble asked on June 12, 2018 21:17

Hello Yall,

Has anybody on the devnet ever used the plugin "WebMarkupMin?"

https://devnet.kentico.com/articles/html-minification-with-webmarkupmin

I've installed it and have been trying to configure it's settings but to no avail.

In the comments the publisher says that it will only run occasionally when "output caching" is enabled.

So I turned that off and still can't get the HTML to minify.

Any Ideas?

Correct Answer

Sir McShneebles answered on June 13, 2018 20:23

Hello YoYo,

I've had similar troubles myself with this plugin, but have recently found the solution.

Perchance, check the comments of the page in question; you can see that the developer Zoltan, says exactly this:

"If you have Output caching enabled, the minification will happen only once in a while, not with each request."

So output caching is a monumental concern. Here are the steps I partook to get the plugin engaged:

  1. log into your environment portal and within the "Settings" app, then go to "System" -> "Performance" and make sure "Output Caching" is disabled.
  2. Make sure that all of your checkboxes are checked for the "HTML Minification" setting in this same window
  3. Then navigation to "System" -> "General" tab and clear your cache and restart your application.
  4. Then clear your browser's cache and history

Once these steps were taken I was able to see all of my HTML minified within the "view source."

It was quite beautiful.

Regards,

Sir McShneebles

0 votesVote for this answer Unmark Correct answer

Recent Answers


Brenden Kehren answered on June 13, 2018 11:35

What have you done to debug the issue? Have you checked out the Kentico event log? IIS Event log? Server Event log?

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.