How to disable showing up Editable regions from masterpage in child pages

Manmath Kulkarni asked on February 2, 2017 12:38


I have created master page template in CMS administration with template type as "Portal Page". In layout I have added editable text in the footer of master page. I have filled up data in those editable region from "Master page's" Page tab and saved it.

Still these editable region keep showing up as Editable in child pages. Is there any way to show these editable regions as normal text in child pages?

Thanks in advance.

Recent Answers

Ilesh Mistry answered on February 2, 2017 13:59

Hi Manmath

I would recommend this...

  1. Go into the Master Page tab (or Design Tab -->Edit Layout), add a Web Part Zone.
  2. Then go to Design tab and add the Editable Text WebPart.
  3. Then go to the page tab, add in your text.
  4. Next go to the sub pages and make sure under the template properties, that that page template is only inheriting the Master Page.

This will work.

1 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on February 2, 2017 14:01


Could you please describe your steps in more details? You have added the editable text control directly into the layout markup? If yes, what is the reason not using the Design tab and adding the web part there? I agree with Ilesh.

Or, are you looking for something like described here?

Or, what about this property of the editable text web part?

0 votesVote for this answer Mark as a Correct answer

Trevor Fayas answered on February 2, 2017 15:16

If it's portal and it's showing up on other pages, it means the other pages are inheriting the master page template, and is a problem.

You should have the Master templtae (header / footer) set to in the Template properties that it's a Master template (it's a checkbox). Add a page placeholder web part on the master page.

Then all sub pages should have a different page template, and make sure they at least inherit the nearest master page.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.