File Import Silverlight plugin error with Kentico 8.2

Jessica Hester asked on March 24, 2017 18:16

I have a client who relies heavily on the File Import function, and their website is currently running 8.2. Yesterday, an error was reported where they cannot upload files using the File Import tool in Chrome, because it requires the use of the Microsoft Silverlight plugin.

Silverlight is deprecated and is no longer supported in Chrome.

I attempted several fixes which did not work, including reinstalling Silverlight, setting the "Use Silverlight Uploader" to true in the web.config file (as well as setting it to false), and even looking for an extension to enable Silverlight for them, all to no avail.

Then I came across this post: https://devnet.kentico.com/questions/silverlight-plug-in, which states that the file uploader has been replaced with an HTML5 uploader, and was implemented in 8.1. This one also says that, by the same support staff member: https://devnet.kentico.com/questions/how-do-i-refresh-the-page-after-files-have-uploaded-with-the-silverlight-direct-file-uploader.

Here is a screenshot, of my client's site, using version 8.2 and receiving the Silverlight error: https://www.screencast.com/t/SmxlpUlq77m.

How do I force Kentico to use the HTML5 uploader for version 8.2? Why am I still seeing this message if Silverlight was scrapped?

Any help is greatly appreciated.

Recent Answers


Brenden Kehren answered on March 24, 2017 18:56

So as your first screenshot shows, it's not a matter of Kentico allowing or not allowing it, it's an issue with Chrome. Chrome no longer supports it. So the solution is to use a browser that supports Silverlight.

Also, it seems you are setting the CMSUseSilverlightUploader to true, which isn't what you want. Set that web.config key to false so it uses the HTML5 version of the uploader.

0 votesVote for this answer Mark as a Correct answer

Jessica Hester answered on March 24, 2017 18:59 (last edited on March 24, 2017 19:40)

Thank you for replying, Brenden. As stated, I actually have tried setting it to false as well.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on March 24, 2017 19:22

Have you contacted Support regarding this? If you're using 8.2.x, it shouldn't even be an issue since it was removed. Is his a recent upgrade? If so, could the client browser be caching it?

0 votesVote for this answer Mark as a Correct answer

Jessica Hester answered on March 24, 2017 19:37

I have not - but I will (I was just trying to follow protocol and make sure there wasn't something obvious I may have missed).

It is a fairly recent launch for a contract that was signed before Kentico 8 was released. So, upgrading to Kentico 10 may fix the problem entirely, but it isn't currently being negotiated.

As far as browser caching, those screenshots were taken from my machine. It is also showing in Firefox. IE is working as intended, though, obviously.

I will contact support and see what they say.

Thank you for your input!

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.