email queue

lawrence whittemore asked on August 16, 2023 14:32

We're having an issue where emails are not being sent out over night when the site is as active. Is there a way to for the scheduler to run without someone being active on the site? We're in kentico 13

Recent Answers

Brenden Kehren answered on August 16, 2023 15:08

With version 13, even if your MVC site is active, your CMS site most likly is not unless someone is in the CMS clicking links. The easiest thing to do is use something like Uptime Robot or App Insights to check this page every 5 or 10 minutes for a 200 response with the value of SCHEDULER_PING_CONTENT_AVAILABILITY as part of the HTML on the page.

This is the quickest, easiest way to keep your CMS site alive and provide you some simple piece of mind that your site is up and running.

0 votesVote for this answer Mark as a Correct answer

lawrence whittemore answered on August 16, 2023 15:35

Thanks for the quick response, I don't think uptime robot will work as the site is internal. We don't use Azure, so I'm not sure if app insights is an option either.

Is this a viable option here?

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on August 16, 2023 15:48

We don't use the scheduler mainly because it's an additional service we have to worry about breaking, it's not easily visible to the normal person looking at your site, and it's an additional application you have to maintain.

We've written a scheduled task to ping the scheduled task page, it works but seems to be counter productive. We've also created a page in the content tree that has a keep alive call to that page I referenced for internal as well. There are options. I shouldn't rule the scheduler out, just not a fan of it personally.

0 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on August 22, 2023 09:23

If the site is internal, use Windows scheduler service.

0 votesVote for this answer Mark as a Correct answer

Dmitry Bastron answered on September 1, 2023 18:45

Hi Lawrence,

Please check web.config of your CMS Admin application whether it has CMSUseAutomaticScheduler disabled by any chance. If it is enabled, the system should automatically keep the process running by pinging ~/CMSPages/Scheduler.ashx route. The default value for this key have changed from false to true from v12 to v13, therefore if you upgraded your solution that key might still be there.

You can read more details in Brian's blog here. Although it mentions scheduled publishing stopping to work, emails are just similar system scheduled task which is dependant on scheduler.

1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.