Why is the 'Maximize the editor size' button missing on my WYSIWYG toolbar?

Keith Murphy asked on March 5, 2014 14:17

I am showing a client the WYSIWYG bar and I noticed that there is no maximize button sometimes. The page that it is missing has no shared toolbar, just the individual toolbars inline. Shouldn't there be a maximize button?

My webpart properties has them: http://screencast.com/t/7yDztmb4ARx On page tab: http://screencast.com/t/zkrhKzZH

Help! Thanks.

Recent Answers

Brenden Kehren answered on March 6, 2014 00:02 (last edited on March 6, 2014 00:02)

My guess is there are UI permissions set for the editor based on a user or role.

1 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on March 8, 2014 08:33 (last edited on March 8, 2014 08:33)


I am just adding link to the documentation on UI permissions

Best regards,
Juraj Ondrus

0 votesVote for this answer Mark as a Correct answer

Lukas Martinak answered on September 22, 2014 18:54

Just a note: there was a change in the CKEditor between Kentico 8 and Kentico 8.1. In Kentico 8.1 the CKEditor has been switched to in-line mode, which means it is no more being rendered to iFrame, but into a div element. This had a side effect that the full screen mode was lost as the CKEditor does not support it in this new in-line mode.

If you want to get it back, you can customize ~\CMSWebParts\Text\editabletext.ascx.cs like this:

Replace ucEditableText.UseInlineMode = true; by ucEditableText.UseInlineMode = false;

I'd recommend cloning the editable text web part first and using your own copy of the web part for editable text where you make that change so the hotfixes and upgrades wouldn't influence you.

0 votesVote for this answer Mark as a Correct answer

Vincent Bedard answered on October 21, 2015 15:13


I tried this :

ucEditableText.UseInlineMode = false;

It's still doesn't work... the button to maximize did not show when the toolbar are Inline. I use 8.2.


0 votesVote for this answer Mark as a Correct answer

S RAHMAN answered on June 29, 2016 15:38 (last edited on June 29, 2016 15:44)

I ran into a similar issue after the 8.0 > 8.1 upgrade. After changing ucEditableText.UseInlineMode = false, you will need to clear your browser cache to see the new changes.

EDIT: disregard. clearing the browser cache did not resolve. opening a case with support.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.