unigrid header row not wrapping

Deanna Martens asked on January 19, 2016 16:48

Good morning,

I have a unigrid that has the wrap property set to true and has a width applied to each column. The problem that I am having is the header row will not word wrap down to the appropriate width. Using the dev tools I was able to see that the header row has the following:

element.style {
    width: 82px;
    white-space: nowrap;

If I manually unchecked that property it will condense the column header but this is not a property I am manually setting.
Any suggestions would be welcomed.

Thank you for your time,

Correct Answer

Trevor Fayas answered on January 19, 2016 19:47

If you simply need to overwrite the default, have you tried using the !important tag at the end of a custom style?

Example, if the element is

you can add a style that goes like this: .SoveDiv { white-space: none !important; }

Although you may need to find the right value, the !important will overwrite the existing value. Hope that helps!

0 votesVote for this answer Unmark Correct answer

Recent Answers

Deanna Martens answered on January 19, 2016 21:27

I wasn't able to just apply that to the column because it affected every row except the header row but I was able to add !important to an internal style for only th and it worked perfectly.

Thank you!

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.