The object type is missing the provider type configuration.

Ricardo Silva asked on July 21, 2017 17:42

Hi,

I'm having an issue syncing a page type change from staging to both production server.

I had this page type called "Policies" with the code name "cms.policies" and one of the admins changed it to "Age Specifics" "cms.agespecifics" but it is not syncing.

SyncServer.ServerError: Exception occurred: [AbstractProvider.GetProvider]: The object type 'cms.document.cms.agespecifics' is missing the provider type configuration.

I tried to restart the application in Kentico and the recycle the pool in IIS, but none of that worked.

Has anyone seem this error before? Or any advice would definitely be appreciated.

Correct Answer

Brenden Kehren answered on July 21, 2017 18:09

Do you currently have any pages using that page type? What I'd do is rename that page type back to what it was then clone the page type to your new page type name. This would ensure you have a clean break from the new and old name. Changing the name after you have code already it (transformations, web part properties, custom code, etc.) can cause a lot of problems and you're better off starting from a scratch or a clone.

0 votesVote for this answer Unmark Correct answer

Recent Answers


Ricardo Silva answered on July 21, 2017 18:24

Hi Brenden, thanks for your input.

In fact I don't have any page using the page type. That seems to be the solution, revert back and start from scratch or a clone.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.