Staging throwing "Synchronization client error: Exception occurred: The request failed with HTTP sta

Shannon Dunn asked on January 3, 2017 18:36

Prior to today, for the most part staging between our test, staging, and production has been working fine. Today I needed to change a single character in an email template, when I went to stage it I got: Synchronization client error: Exception occurred: The request failed with HTTP status 403: Forbidden. I tried repeatedly to redo it, and it throws the error still. We have seen in the past where it will do it once and on the second try it works. This time nope.

I have other pending tasks but I just wanted to sync this single one. Same error happens on our staging and test servers. Any ideas?

Correct Answer

Shannon Dunn answered on January 10, 2017 20:04

So I figured out the issue. We use CloudFlare and it was blocking the request. The reason that it was blocking this versus other content inside of staging (thus not an environment issue) is that the email template contained content that was deemed bad by CloudFlare. Thus it blocked. To fix I just added the staging web page for all servers in my domain to the whitelist in CloudFlare and removed WAP from it. Works fine now. Just wanted to post it back as an answer incase someone else run into this since CloudFlare is a tricky sucker and in use more and more by the day.

1 votesVote for this answer Unmark Correct answer

Recent Answers

Brenden Kehren answered on January 3, 2017 19:02

Hey Shannon!

Anything change in the network or infrastructure? Expired certificate? Windows updates installed and causing problems?

Credentials updated in staging? This happens to me all the time because some browsers will overwrite an empty field with auto populated values you've cached in the browser. So maybe inadvertently changed user and pass?

And of course the typical questions:

  • Is it plugged in?
  • Is the power switch on?
  • Is the blinker fluid full?


1 votesVote for this answer Mark as a Correct answer

Dennis Hulsmans answered on January 4, 2017 17:11

403 Forbidden, seems like you aren't allowed to use the service (CMSPages\Staging\SyncServer.asmx) We had the same issue a few days ago, the staging password had been overwritten by the browser or something. I changed it back to the correct password, and the staging application works again.

KR, Dennis

0 votesVote for this answer Mark as a Correct answer

Shannon Dunn answered on January 5, 2017 17:15

I would say it is a password issue, as I have had Chrome go stupid on Kentico's search field in the backend and stick my name in but its working for the Pages module and other areas that are content related. It seems right now that only Email Template's are throwing this issue although we have not done a complete test of all areas.

Brenden, would any of those cause issues if Pages is working fine to sync?

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.