NoIndex (Exclude From Search Function) Not Working

Danny Butler asked on April 9, 2019 03:56

HI all,

There appears to be issues when we're trying to "exclude from search" in Kentico.

We're using Kentico version 8 and trying to prune the website of thin/duplicate content. There's a lot of legacy pages and parent folders that need to be noindexed. For example - domain.com.au/footer-links/industries

I've checked the serps and GWT and the pages are still indexed and I've viewed the page source and looked for the NoIndex meta tag and it is nowhere to be seen.

Has the "exclude from search" function now deprecated because we're using such an old version?

Any help/insights would be greatly appreciated.

Cheers,

Danny

Recent Answers


Juraj Ondrus answered on April 9, 2019 08:57

If you want to disable the search engines from indexing the pages, use the robots.txt file. The setting you are refering to applies for local, Smart search indexes and removes the page from the sitemap. Also, it may take some time to re-crawl your site and you may need to submit the request in the search engine webmaster tools.

0 votesVote for this answer Mark as a Correct answer

Danny Butler answered on April 10, 2019 00:26

Hi Juraj,

Thanks for your response! However on the Kentico documentation, it says that this function does add the <meta name="robots" content="noindex,nofollow" which I'm looking for:

Excluding pages manually

You can also configure individual pages to be excluded from search engine listings without the need to prepare a robots.txt file.

Open the Pages application. Select the given page in the content tree. Open the Properties -> Navigation tab. Enable the Exclude from search property. Click Save. The system automatically adds the following meta tag to the

0 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on April 10, 2019 10:41 (last edited on April 10, 2019 10:41)

What is the version of Kentico you are using? I tried it on Kentico 8.2 and it is working fine. Maybe you are facing some bug which was fixed in newer Kentico version.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on April 10, 2019 16:18

Danny,

Assuming you've already done this:

Navigate to Properties -> Navigation tab on the page you want to exclude and check the Exclude from search property and save.

YOu may need to clear the cache on your site or restart your site to see the changes immediately.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.