New Smart Search Index Not Working

Jon Truelove asked on August 22, 2017 15:53

Hello. I'm new to Kentico (we're using v9). So I created a new Search Index, tested it using the "Search Preview" feature (works great). I rebuilt the index and it is optimized. Problem is, this is not being reflected on the live site. How would you recommend I start troubleshooting this? Thanks!

Correct Answer

Brenden Kehren answered on August 22, 2017 17:39

In the page template utilized by your search page, there should be a smart search results webpart. In that webpart there is a property for the smart search index. Make sure it is selected with your new index. Might need to share a screenshot of your template design view and/or your webpart settings.

0 votesVote for this answer Unmark Correct answer

Recent Answers


Brenden Kehren answered on August 22, 2017 15:56

Check the page template and the webpart settings to ensure they are using your new search index you created.

1 votesVote for this answer Mark as a Correct answer

Jon Truelove answered on August 22, 2017 17:36

Thanks for the quick reply. I'm not seeing anything in my page template settings or web part settings that references any search index whatsoever. Could you help steer me in right direction? Thanks again.

0 votesVote for this answer Mark as a Correct answer

Rui Wang answered on August 22, 2017 17:53

0 votesVote for this answer Mark as a Correct answer

Jon Truelove answered on August 22, 2017 18:00

Thanks, guys. I got it working now. As Brenden alluded to, I needed to go into the "Smart search dialog with results" web part and include my new index name in the "Indexes" input field. I don't think this step is mentioned anywhere in the documentation...anyway, thanks again!

0 votesVote for this answer Mark as a Correct answer

Rui Wang answered on August 22, 2017 18:02 (last edited on August 22, 2017 21:09)

Jon, please read carefully again. First row in that documentation page table.

Indexes | Determines which index the search uses. You can select multiple search indexes.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.