Kentico 8.2 site export contains no pages?

Christian Nickel asked on July 31, 2017 15:10

Our Kentico 8.2.50 instance is hosting two unrelated sites, when exporting the sites individually the first (Site A, which contains over 2000 pages) exports without any issues, I can restore all the pages in a different instance. Exporting the second site (Site B, with only 190 pages) fails to export any pages and I can't figure out why.

The export log for Site B says it has exported the pages, page histories, etc. But when I import into a different instance (same version, hotfix, etc) it will not import any pages... it goes through the step, but no pages are added to the site.

Nothing appears in the event log which would indicate why, included in the export are all the page types, templates, and modules for that site. Could someone point me in the right direction as to where to look?

Correct Answer

Christian Nickel answered on July 31, 2017 17:53

I've figured this out, thanks to both of you for your help!

Turns out that the page-type "Root" was never assigned to "Site B". So even though I could see "Root" as a page type in the Export Wizard as a global object, it was never assigned so the export never included the Root page of Site B. So, assigning it, exporting again, and then importing finally imported all of the pages!

Honestly I'm not sure how the site has worked so long without "Root" being assigned to it.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Trevor Fayas answered on July 31, 2017 15:32

Let's try to break this down and diagnose it.

  1. Open up your exported ZIP file, and take a look at the content, there should be a file that is for any document meta data (export converts Database objects into a Serializable/deseriable xml file, one for each object more or less). Do you see any of the pages you want to export? If not then we need to debug the export.
  2. If you do see files, when you import, are there certain checkboxes that aren't being checked to make sure to import the correct items? Have you tried using the Site Wizard to set up a new site using that exported site instead of creating a site and importing into it?
  3. Does the new Site (Site B) have existing documents? Maybe it's not overwriting them or something.

Check those steps out and report back and we'll help ya!

0 votesVote for this answer Mark as a Correct answer

Jan Šedo answered on July 31, 2017 15:36 (last edited on July 31, 2017 15:37)

Make sure that site B has CMS.Root page type assigned to it (you can check this in Page types > (select CMS.Root) > Sites). If it is not, pages will be exported, however on the target instance they will miss the parent node so they won't be created.

1 votesVote for this answer Mark as a Correct answer

Christian Nickel answered on July 31, 2017 17:06

@Trevor - Thank you for the detail you put into your answer! 1. The zip contains the files I would expect to see, including the extra Root page which I didn't have before, under Data\Documents there is a file called cms_document.xml.export which has all the documents. 2. A - I see the files so I don't think that is an issue. I use the same options to export that I use for Site A, all the options to export pages under Website --> Content Management --> Pages are selected. 2. B - Yes I've tried Site Wizard to create a new site and I get the same result, only the root page exists (and has the correct template applied). 3. I've tried doing this with and without existing documents, for an existing site and a brand new site... same issue.

@Jan - Great idea and I just tried this, Site B did not have Root selected in the original exports. This still did not solve the problem, importing the site had the same issues as it did not import any pages. The export was slightly larger (by about 9 kilobytes) but this did not change the result.

Is there are more detailed log of the import (or export) anywhere I could look at?

0 votesVote for this answer Mark as a Correct answer

Trevor Fayas answered on July 31, 2017 17:16

Okay a couple more things to check/try

  1. Does the new site you are importing to have the right culture? if you import from a site of one culture and try to import into a site that doesn't have that culture, it probably won't import.

  2. Are the sites you are importing from in any form of a workflow, and in an unpublished or edit mode state? Grasping at straws but maybe the documents are in a workflow state that the new site doesn't have so it's not importing them? : /

  3. Was there any custom Child/Parent allowed types that was unique that may be in conflict? I could imagine that if it required a certain page type to allow a child, but the other site has a different setting that it would fail to set the things right because it would be prevented from changing it in a way that would mess up the other site.

You stated you tried on a new site, is this a new Kentico instance or a new site on that existing Kentico instance? If it's not a brand new instance, maybe try spinning up a quick local instance and see if that allows you to, at least that would eliminate the export from being the issue.

0 votesVote for this answer Mark as a Correct answer

Christian Nickel answered on July 31, 2017 17:17

I just noticed that the import process doesn't have an entry for "Importing Pages", shouldn't there be an entry like that?

The export has these entries in the following order:

Exporting Workflow histories
Exporting Attachment histories
Exporting Version histories
Exporting Page relationships
Exporting Attachment
Exporting ACLs
Exporting Pages

The import has the following entries that seem to match, minus the "Importing Pages"

Importing Page aliases
Importing additional page properties
Importing Workflow histories
Importing Version histories
Importing Attachment
Importing ACL items
Importing ACLs

Not sure if that is related to the issue or not.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.