Inheritence on Page Title is being Ignore

Andrea McCabe asked on November 29, 2018 21:47

I have a global setting for the page title: {% CurrentDocument.DocumentName #%} - {% CurrentPageInfo.DocumentNamePath.Split("/")[1] #%}

On the Home Page under Meta Data Settings I have the Inherit checkbox unchecked and it says "Industry Solutions - A New Approach to Serving Industry."

Yet when the page loads in the browser the Title tag appears as the inherited setting instead of the individual setting under Meta Data.

I have double checked the CMS_Document database table to make sure the Document Page Title is listed as "Industry Solutions - A New Approach to Serving Industry."

Is there another setting that needs to be set so that it won't inherit when the meta data is set on the individual page?

Correct Answer

Juraj Ondrus answered on November 30, 2018 10:26

Hi,
When you set some specific macro into the settings, this one is resolved - so, you should use a macro which will resolve the Page title field. For example: {%pagetitle_orelse_name%}. This means that the value of the Page title field of the page is being looked up. Then, if you want to have some default value, set the {% CurrentDocument.DocumentName #%} - {% CurrentPageInfo.DocumentNamePath.Split("/")[1] #%} macro to the root page's Metadata section.

0 votesVote for this answer Unmark Correct answer

Recent Answers


Andrea McCabe answered on December 7, 2018 22:38

Hi Juraj,

That worked! Thanks so much for your help!

Andrea M.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.