How to disable the browser login prompt when using Windows Authentication?

Kentico Support Engineer asked on June 12, 2013 14:38

How to disable the browser login prompt when using Windows Authentication?

Correct Answer

Kentico Support Engineer answered on June 12, 2013 14:38

This is not a Kentico CMS setting, instead this is a browser (client side) setting. In order for the browser to not display the login prompt, the site has to be added to the list of trusted sites. The setup varies from browser to browser:

Internet Explorer:
You will need to add your site to the list of trusted sites in:
Internet Options -> Security -> Trusted sites -> Sites

You may also need to disable https authentication in the same place, if you have not set this up on your site.  Alternatively, you can turn on automatic intranet network detection in:
Internet Options -> Security -> Local intranet -> Sites

However, this is not guaranteed to work and will not work for Internet websites.

Chrome takes its trusted sites settings from the same Internet Options as Internet Explorer. You can access the dialog from Chrome here:

Properties -> Show advanced settings -> Change proxy settings -> Security -> Trusted sites

Please note: you will be asked to log in the first time you access the trusted site.

Mozilla Firefox:
The Firefox browser does not offer any trusted sites settings in the properties dialog; however it does provide a configuration string which can be modified to enable this functionality. Enter about:config into the address bar, enter and confirm the safety check. Search or create the preference string network.automatic-ntlm-auth.trusted-uris. Afterwards enter trusted site names as list separated by comma and space. For example like this: intra, intranet, localhost

0 votesVote for this answer Unmark Correct answer

   Please, sign in to be able to submit a new answer.