Failed to load dialog parameters (v12.0.103) Portal Engine

Sean Lamacraft asked on April 16, 2024 09:43

Our site in running on Kentico V12 (v12.0.103)Portal engine. We seem to have an issue in the CMS that is preventing us from using any dialog that is opened. It appears to be CMS-wide, so dialogs for adding properties on Web Parts, Selecting allowed types, etc.

This is the error we see when trying to open any dialog.

Failed to load dialog parameters - The dialog parameters are not consistent, please try to reopen the dialog.

We tried running the site in both IIS and Express. I've resigned all the macros, and changed folder permissions, but still have the same issues. It works on the Staging Environment, so I tried to bring down a backup of the DB to run locally, but still have the same issue.

There are no errors in the Event log, but the browser console shows this: Text http://lords.local/CMSMessages/Error.aspx?title=dialogs.badhashtitle&text=dialogs.badhashtext&hash=baf1a35f62cc37773b97cfbd618406859ee5c6abbe93bf5189733e18e4c81b51&cancel=1 500 (Internal Server Error)

Has anyone seen this before?

Recent Answers

Brenden Kehren answered on April 16, 2024 16:12

The URL has a 500 error tacked on to the end of it. Has your license expired? Typically when you go to the public site with an expired license, you'll get some sort of 500 error. However, you should be able to navigate to the CMS and log in.

If it's not a license error, then try to debug locally. The 500 error is code/server error that should provide you with more info either in the browser when running locally or in the IIS or server event logs.

0 votesVote for this answer Mark as a Correct answer

Elmar Höfinghoff answered on April 22, 2024 09:04

Have you tried to delete the whole bin and obj folders and rebuild again? Sometimes old files within these folders, espacially in the bin, can cause strange things. Would asume it is caused by something in the file system if it works on your staging environment.

0 votesVote for this answer Mark as a Correct answer

Juraj Ondrus answered on April 26, 2024 05:35 (last edited on April 26, 2024 05:40)

I guess it started happening just recently - so I would check what changes were made. This sounds more like something in the environment changes, maybe security settings. If it works on one environment and not other, it does not sound like a Kentico issue but rather something in the environment. As mentioned by Brenden, check the errors, compare the environment setup, security settings, CSPs, headers, etc.
Anything different in the web.config file? HTTS/SSL certificates are OK? Are you using secured cookies too (RequireSSL)? Aren't the cookies blocked?
Is Use SSL for administration interface set to true in Settings > Security & Membership?

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.