Document Repeater pulls "denied" documents

Kayla Johnson asked on February 20, 2018 01:42

We have a repeater that pulls File documents on a page. However some of the documents should not be available to certain users, so they are set to Deny for that User Role. However, they are still getting pulled in the Repeater. The access denied does not show until they click on the link to view the File. However this is not desirable. The "denied" File should not show in the Repeater at all. How can we accomplish this?

Correct Answer

Brenden Kehren answered on February 20, 2018 02:29

On the repeater properties, make sure you have the "check permissions" Checkbox checked. This will ensure those permissions are followed.

1 votesVote for this answer Unmark Correct answer

Recent Answers

Juraj Ondrus answered on February 20, 2018 08:34

And maybe some additional note, you can also set the Check permissions for all pages or just secured areas. More details can be found in the documentation on hiding pages based on permissions

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.