'Delete' action not functioning

Regis Wengel asked on March 14, 2019 23:15

I recently upgraded a site from Kentico 10 - 12.0.13. The site is not MVC.

I went into the Licenses application to update the license. I click the delete icon, the prompt comes up and I confirm the deletion. Nothing happens. I have even tried clicking the triple ... and clicked destroy and the license still isn't deleted.

I can view and export the license, but deleting it doesn't work. I tried this in a few other applications as well. I can't delete any Domain aliases', resource strings, or users. My assumption is this delete button isn't working anywhere. All of the other icons work as expected. Just trying to delete the object fails.

I've restarted the site. There's no errors in the event log. It doesn't event look like the site is sending a delete request (normally you get the waiting for...{site} pop up in the browser corner. Here I'm not).

The console is giving me the following warning and error:

When I click delete: unreachable code after return statement

When I confirm the pop-up: TypeError: access to strict mode caller function is censored

I'm not really sure what to do to fix this issue.

Correct Answer

Brenden Kehren answered on March 15, 2019 06:09

Did your upgrade from 10 to 11 succeed? What about 11 to 12? Did you receive the upgrade start and finish messages in the event log? Have you cleared the cache? My guess is you have old JS files cached.

1 votesVote for this answer Unmark Correct answer

   Please, sign in to be able to submit a new answer.