Can't save new web part layout.

Targutai Yesugei asked on June 26, 2017 12:07


Just enсountered an error, when i can't save web part's layout in UI, neither from web part properties in "Design" tab, nor from the "Web part" tile configuration.

When i'm pressing "Apply" or "Save" or "Save & Close" button there is an error

Uncaught Error: Sys.InvalidOperationException: Could not find UpdatePanel with ID 'm_c_ucHierarchy_mainLayout_mainPane_layoutElem_paneToolbar_pnlUpdate'. If it is being updated dynamically then it must be inside another UpdatePanel.
at Function.H.w.create (ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LfB7-HqXpRMt1AtR3It-S4NsxS0wCac2fQ0G2rxDyFF83Lqpr9-r3JsQnw…:2)
at Object.H.b._error (ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LfB7-HqXpRMt1AtR3It-S4NsxS0wCac2fQ0G2rxDyFF83Lqpr9-r3JsQnw…:2)
at Function.H.w.invalidOperation (ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LfB7-HqXpRMt1AtR3It-S4NsxS0wCac2fQ0G2rxDyFF83Lqpr9-r3JsQnw…:2)
at Sys.WebForms.PageRequestManager._onFormSubmitCompleted (ScriptResource.axd?d=P5lTttoqSeZXoYRLQMIScKeUODDPLIz6_BoOMIpDIu_esDF7gJDqbuowYJEzpP9gBxmLU7xbYkRtr1…:2)
at Array.<anonymous> (ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LfB7-HqXpRMt1AtR3It-S4NsxS0wCac2fQ0G2rxDyFF83Lqpr9-r3JsQnw…:2)
at ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LfB7-HqXpRMt1AtR3It-S4NsxS0wCac2fQ0G2rxDyFF83Lqpr9-r3JsQnw…:2
at d (ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LfB7-HqXpRMt1AtR3It-S4NsxS0wCac2fQ0G2rxDyFF83Lqpr9-r3JsQnw…:2)
at H.b.Net.WebRequest.completed (ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LfB7-HqXpRMt1AtR3It-S4NsxS0wCac2fQ0G2rxDyFF83Lqpr9-r3JsQnw…:2)

popping in my face.

Can anyone help me with this problem?

UPDATE I'm using Google Chrome, when i tried to work in incognito window, this error disappeared and saving worked.

Correct Answer

Targutai Yesugei answered on June 27, 2017 05:58

Clearing cache and cookies fixed the problem, thanks a lot!

0 votesVote for this answer Unmark Correct answer

Recent Answers

Roman Hutnyk answered on June 26, 2017 14:36

First I'd try is clearing the cache and restarting Kentico.

Also you may need to apply hotfix to your installation.

1 votesVote for this answer Mark as a Correct answer

Trevor Fayas answered on June 26, 2017 16:03

Based on your update, if Incognito window works on Chrome, then may be an addon interfering (or your browser cache). First try clearing cache and cookies. If that doesn't work, I would disable all addons, see if it works, and if so then one by one turn them back on and test to see which is the problem.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on June 26, 2017 16:17

When you saved the new layout did you delete any of the controls from the layout? If so, this will cause errors because there are typically dependencies in the code behind files which you are not modifying. If you did remove controls, then add them back and set the visibility to false or wrap them in a div and hide the div.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.