Widgets not saving properly

Mike Bilz asked on May 25, 2017 01:46

Hello Kentico Team,

My editors are noticing an issue with our site. When an editor makes a change to a Widget and then presses "Save & Close" the changes they made are not saved, the widget reverts to the previous content from before the edit was made.

Even if the editor clicks "Apply" first, the widget may still revert to a previous version when the editor clicks "Save & Close". Clicking "Apply" twice seems to have more consistent results, but that is a little too goofy of a fix for my liking.

Has anyone encountered something like this before? Is there a setting or configuration issue at play here? Is there an issue with the site's cache?

Any assistance would be greatly appreciated. Thanks in advance!

-mike

Recent Answers


Prashant Verma answered on May 25, 2017 02:19 (last edited on May 25, 2017 05:32)

Hi Mike,

I also facing same problem with widget during edit and save in kentico 10.

If you are using kentico 10.0.0 version there is a bug with widget save functionality for losing the content.To resolve this issue you need to apply hotfix version 10.0.14.

For verification what defect fixed in hotfix version you can read hotfix fixed bugs logs.

Thanks

Happy to help you

1 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on May 25, 2017 03:02

Mike, this can happen with invalid markup and/or javascript errors on the page. I've also seen bugs like Prashant mentions. Take a look at the bug list and see if your version has something there.

1 votesVote for this answer Mark as a Correct answer

Gina Kosak answered on May 31, 2017 15:45 (last edited on May 31, 2017 20:05)

I am also having the same issue on version 9. I can make a few changes and it works however most changes do not save on the page and I had one revert to information that was there a year ago. Is there a hotfix for version 9 with this issue (I did not find one in the listings) or could it be a cache issue?

0 votesVote for this answer Mark as a Correct answer

Youssef Kettani answered on October 17, 2017 19:41

Hi Mike and everyone,

We too have been experiencing widgets just not saving the updates and the page reloading losing precious work. We have two different Kentico environnements, both running version 9.

I will ask Kentico if we could have the fix 10.0.14 prepared for version 9, but the description seems a bit different from what we are experiencing (it seems to happen for most widgets, especially the ones with complicated configurations). The description of 10.0.14 is

In certain cases, the Editable text widget could lose its content when moved from one widget zone to another.

Will let you know if I find anything.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.