Website does not render on desktop until I open it on webserver

Woodley Westbrook asked on November 27, 2018 23:44

Hello Kentico DevNet,

We have created a Kentico website and it is up and running on our web server. We are also able to access the "admin" portion of it on the web server without any difficulties.

Where we run into difficulty is accessing the site from our desktops. We get the following message (browser dependent): This page isn’t working redirected you too many times.Try clearing your cookies.ERR_TOO_MANY_REDIRECTS

What we find strange is that when we access the site from the web server using a particular browser we can then access the site from our desktop using only that same browser. It isn't until we access the site with another browser will we then be able to do the same on our desktop. What is even stranger is that we will not be able to navigate to any additional pages until we have done so on the web server.

We are using v10.0.50 We imported the site (it was not built from scratch).

Any assistance in helping us figure out why we cannot access the site on our desktops until we access on same browser on web server first would be appreciated.

We think it might be "session" based because the effect last less than a hour and then we have to repeat all over again in order to access on desktop. Problem is we cannot figure out where to start.

If I left out any details please let me know.


Woodley Westbrook

Recent Answers

Brenden Kehren answered on November 28, 2018 16:28

The ERR_TOO_MANY_REDIRECTS error is usually a setup problem. Make sure you have a few things setup properly:

  • Check your web.config for any custom URL Redirects, ensure they are valid
  • Check the bindings in IIS to ensure they are properly setup for the domain
  • Check the following Kentico Settings:
  • Settings > URLs & SEO > SEO - URLs > Process domain prefix - in production, make sure this is set to use www or no www. Mainly for SEO but if you don't set it, it could cause problems.
  • Settings > URLs & SEO > SEO - URLs > Default page - make sure this is set to Use domain root
  • Settings > Content > Web site content > Default alias path - make sure this is set to your "Home" page, usually /home
  • Check the following Site configuration:
  • Sites > [YOUR SITE] > Site domain name - make sure this is set to the published domain like
  • Sites > [YOUR SITE] > Domain aliases - make sure you have an alias setup which includes the "www" if your site domain name does not contain it. And visa versa if your site domain name includes "www", make sure you have an alias without the "www" added. Do not add any redirects in the aliases.
3 votesVote for this answer Mark as a Correct answer

Woodley Westbrook answered on November 30, 2018 16:15

Hello Brenden,

Thanks for answering.

  • We checked the web.config but there are no Redirects.
  • Double checked the Bindings in IIS and nothing appears to be out of order there. Standard configuration of port 80 and port 443.

In Kentico

  • I set the "Settings > URLs & SEO > SEO - URLs" to exactly what you provided for both Process domain prefix and Default page.
  • And did the same for Settings > Content > Web site content > Default alias path.
  • I also adjusted our "Site domain name" and "Domain aliases" to what you suggested.

After implementing all of the above updates nothing changed. The site still operates correctly when I remote to the server but will not render on anyone's desktop.

Brenden, I failed to mention that this site was exported to us from a consultant. So we imported this site into the Kentico environment. It was not a "new" build. Not sure if this important but thought I would bring it up.

Again, thanks for any assistance you could provide.

Woodley Westbrook

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.