Web part is not getting deleted

Anshul meena asked on December 14, 2017 17:38

I added JavaScript web-part for testing some scripts. Now I want to simply delete this web-part.

  1. I have tried remove option on the web-part.

Please don't answer this question if you can't answer it in straight forward steps. Also don't just create any other question and try to answer that(kentico mvp are doing this).

Recent Answers

Laura Frese answered on December 14, 2017 22:07

Did you try to delete it?

2 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on December 14, 2017 22:21

There are issues with the webpart specifically when there is some js code that conflicts or has errors. By design the webpart does not execute the javascript when in the design or edit mode as to not conflict with the UI pieces. What is most likely happening is either you have some conflicting JS or bad HTML.

In the event you are unable to use the Design tab to remove the webpart you have 2 options:

  1. Go to the Templates app, find the template, on the design tab, attempt to remove the webpart there.
  2. If #1 does not work, then in the Templates app on the template in question, go to the Webparts tab and look through the raw XML and find the <webpart> node and remove it.

If none of these things resolve it, I'm assuming you tried the items in the accepted answer on this post you already commented on?

Lastly, if people would provide more information when asking questions then we wouldn't have to ask more questions. Instead of criticizing the MVPs for asking questions, you should be thankful they are willing to take time out of their day to help others (with poorly formed questions) with their issues. If this question was on Stackoverflow, it would have been down voted and flagged for removal because of the lack of information.

P.S. if you don't like the answers (or questions) you get from volunteers on the DevNet, I suggest contacting Kentico Support, where they too, will ask you questions.

2 votesVote for this answer Mark as a Correct answer

Eric Dugre answered on December 14, 2017 23:53

Hello Anshul,

As Brenden has already stated, we need more information to determine why this isn't working for you. In most cases, we can't provide straightforward steps to resolve the issue if we don't know what is causing it. You can see examples of helpful information to include in your DevNet questions or Support tickets here: https://devnet.kentico.com/articles/wanna-get-better-and-faster-support-answers.

For example:

  • Including the version of Kentico (with hotfix) you're using can help us determine whether you're experiencing a bug that has already been fixed. What hotfix version of Kentico 9 are you using?
  • Checking the Event Log for error messages also helps in many cases. Have you checked this?
  • Since your issue may be related to javascript, have you used your browser's Developer Tools (F12) to see if there are javascript errors in the Console?

Brendan has also provided two very helpful solutions that should resolve your issue. Please let us know if you have tried the recommended solutions, and provide additional information if they didn't help. If they did help, don't forget to thank him!

1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.