Web analytics log not working

Farah El Agha asked on January 11, 2018 09:52

Hi, I followed the steps to enable the web analytics feature by following these steps:

1- Open the Settings application.

2- Select the On-line marketing -> Web Analytics category.

3- Check Enable web analytics.

4- Save the settings.

And I have updated the ASP.NET account permissions to Modify, but still it didnt work, no records found in the database tables (Analytics_DayHits, Analytics_HourHits...), does someone have any idea what am I missing?

Recent Answers


Brenden Kehren answered on January 11, 2018 15:14

Have you checked the event logs in Kentico and in IIS? They might tell you a bit more as to what is going on.

1 votesVote for this answer Mark as a Correct answer

Farah El Agha answered on January 11, 2018 15:19 (last edited on January 11, 2018 16:38)

No there are no errors, I need the web analytics to sort some data by the number of views, so after enabling it, I noticed that no data were registered in the database. I was following your answer on: https://devnet.kentico.com/questions/filter-content-by-the-number-of-users-views to sort the records by number of views but I got stuck in web analytics not enabling.

0 votesVote for this answer Mark as a Correct answer

Athena Allison answered on January 12, 2018 14:58

Did you realize that 98% of your site company for custom essay writing guests never leave their contact data? web analytics instruments that your business requires, the plenty of accessible choices can be overpowering for organizations that may not see how to utilize them.

0 votesVote for this answer Mark as a Correct answer

Kenny Deblaere answered on January 12, 2018 16:26 (last edited on January 12, 2018 16:37)

Did you enable the 'Log on-line marketing activity' on the pages module? You can find it on General (the tab, itself) > Online Marketing ?

0 votesVote for this answer Mark as a Correct answer

Farah El Agha answered on January 12, 2018 16:49

yes I did, though the same result, database tables are empty, and in the App_Data>CMSModule>WebAnalytics I have a folder called MaxMind and in it there is a file called GeoLiteCity.dat nothing else.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.