Unable to hotfix - Microsoft.Web.Administration

Olga Travlos asked on May 8, 2017 12:51

Hi

I have downloaded Kentico (v10) fresh from the Portal and ran the installer to create a blank portal project on my local machine. My local machine is Windows 10 Pro 64bit. If I try to run the hotfixes from the installation manager I get the following error http://imgur.com/a/mD9gu. If I download and run the hotfix exe I also get this error.

I have been told by a support engineer:

When you initially installed Kentico did you get the installer from the Client Portal (client.kentico.com), and were the htofix.exe files downloaded from https://devnet.kentico.com/download/hotfixes ?  It is possible that the installation packages are an old version or could have become corrupt.   Additionally, does the folder C:\Windows\WinSxS\msil_microsoft.web.administration_31bf3856ad364e35_6.3.9600.17042_none_4ba6e63aae25ce48  exist on your filesystem and does it contain the Microsoft.Web.Administration.dll file?

In the (very few) cases I could find in the past with similar errors the customers addressed the issue in two ways:


    *1.  They re-installed the Kentico program files with a newly downloaded Kentico installer from the Client Portal then manually applied the hotfix with a newly downloaded executable from https://devnet.kentico.com/download/hotfixes . More information on re-installing only program files can be found here:*

    *https://docs.kentico.com/k10/installation/installing-kentico-questions-and-answers#InstallingKentico(QuestionsandAnswers)-WhenshouldIinstallonlyprogramfiles?* 

    *Please ensure you have an up-to-date backup of the project before attempting a re-installation.  You will not lose your Kentico website during the re-installation process unless you select to do so in the wizard.*

    *2. The second option that helped a customer in one instance, was they copied the folder (containing the .dll) mentioned above between their environments, as it was missing in one of their environments and attempted the process again.*

Everything was downloaded fresh from Kentico before beginning this process, I have also tried this on 2 other PC's (also Win 10 Pro 64bit) and get the same error.

I am not sure what is meant by copying the DLL between environments, the DLL exists in my file system, but is 6.1.7601.17514. We have tried opening the project in VS and using NuGet to download Microsoft.Web.Administration - Version 7.0.0.0 but for some reason this is coming down as the Microsoft.Web.Administration.dll I already have (6.1.7601.17514).

We have a project to start and I'd rather start with an up to date hot-fixed v10. Please help.

Recent Answers


Trevor Fayas answered on May 8, 2017 16:05

Did you run the newly installed site before running the hotfix? It's possible that some first-time run procedures didn't get to run because you installed and immediately upgraded. Shot in the dark, but i know it's a big issue when you do major upgrades.

I do know you shouldn't need to install any nuget packages.

What you can try is copying the LIB contents into the site's BIN folder, if any drivers are missing.

0 votesVote for this answer Mark as a Correct answer

endurit gmbh answered on May 31, 2017 01:05

I had the exact same problem, but found a solution. Here's how I got it to work:

  1. Download the manual upgrade from here: https://devnet.kentico.com/download/upgrades
  2. Install it somewhere
  3. Go to that install dir and place there the Microsoft.web.Administration.dll (right next to the Upgrade.exe)
  4. Execute "Upgrade.exe" and it should work!

Seems like the setup cannot find the .dll somewhere else in the system, altough it is also in the same folder as the KIM.exe.

Anyways, I hope that helps you out.

0 votesVote for this answer Mark as a Correct answer

David Pearson answered on June 29, 2017 16:14

I am having the same issue with Kentico 10. I installed Kentico 10 with the installer. Created new website, then went to install patches. Results same error.

Not sure if I understand Endurit solution correctly.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.