Unable to change casing of default string using Localization

Tim Sieberg asked on February 21, 2018 23:04

We are using the Logon Form web part and allowing forgotten password retrieval which shows a button on the UI with the text "Reset password". We would like that to read "Reset Password", the only difference being the uppercase P.

I tried to create a Localization string with key of LogonForm.btnPasswordRetrieval and having the value "Reset Password". When I save that, the value of the localization string is automatically changed back to "Reset password". I can change the value to something completely different, and it will save, but if its the same letters but different casing that the original, it won't stick.

Is this a bug, or am I doing something wrong?

Correct Answer

Brenden Kehren answered on February 22, 2018 18:13

Tried and had same results in a v10 instance and v9 instance. I'd suggest reporting this to Kentico as a bug. In the meantime, the fix for you would be to go to the /CMSResources/CMS.resx file and find that key and modify the value.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Brenden Kehren answered on February 21, 2018 23:29

Assuming you have created it in the Localization app and not modified the CMS.resx file AND not changed any of the defaults as to how Kentico retrieves those values; the database value will take priority over the value in the CMS.resx file. What I believe might be happening is the page is cached for whatever reason and displaying that old lowercase value. I'd suggest making the edit in the localization app, clearing the cache in the site, then clearing the cache in your browser and try again in a private browser window.

0 votesVote for this answer Mark as a Correct answer

Tim Sieberg answered on February 22, 2018 18:06

Yes, I am using the Localization app. I would appreciate it someone else could try this:
1. Open Localization App
2. Create New String
Key = LogonForm.btnPasswordRetrieval
English Value = Reset Password
3. Save the changes
4. Close and reopen Localization app
5. Expected is a new key with value of Reset Password
Actual is no value displayed on Resource Strings listing, and clicking on the new string shows Reset password

0 votesVote for this answer Mark as a Correct answer

Tim Sieberg answered on February 28, 2018 21:31

As a follow-up, this was confirmed as a bug in the 10.0.0 version that I'm using. It's believed to be fixed in 10.0.19 which I have not upgraded to yet, but will be soon. Meanwhile, the workaround to modify the CMS.resx is working for me.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.