There’s an issue with the Content tree - nodes can’t expand. What’s going wrong?

HelenaG Grulichova asked on April 4, 2011 07:42

There’s an issue with the Content tree - nodes can’t expand. What’s going wrong?

Correct Answer

HelenaG Grulichova answered on April 4, 2011 07:42

Generally speaking, the ScriptResource files (the .axd files) are not loaded properly (404 error).
There are 2 possible causes of this issue (as far as we’re concerned):

1) It may be that your IIS server can't handle them - the .axd files are not allowed. Please configure the handler mappings as described here:

Another possible cause, when speaking about the IIS settings, can be the "Invoke handler only if request is mapped to file" option (it is called "Verify that file exists" in IIS6) - this needs to be unchecked. It is further discussed here:

In case you use a shared hosting environment, please contact your hosting provider to check, whether they have enabled the .axd files support on their server. Ask them whether there any restrictions for those script resources files.

2) It is also possible that you are missing the ScriptResource registration within handlers section of your web.config file ( Please add the following line (in bold) to the system.webServer section:

<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

If you are missing the enwrapping handlers section, so please add it as well. The above registration applies to .NET 3.5. Should you use .NET 2.0 version, please use the following one:

<add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

Afterwards, please restart your application and it should work as expected.

0 votesVote for this answer Unmark Correct answer

   Please, sign in to be able to submit a new answer.