Source Page URL for Dynamic Newsletter 'Page Not Found'

Bruce Williams asked on December 1, 2016 16:10

Hi everyone. we are creating a dynamic newsletter in v9 EMS and we are getting error on the actual site domain name and page for the source page url.

Not really sure why this is occuring. It is our site domain name and the page is definitely published. Why would this be happening? it gives no real solid exception message.

Correct Answer

Brenden Kehren answered on December 1, 2016 16:22

Bruce, when you are sending this are you sending it to an actual subscriber or just testing the send? I ran into issues when I wasn't actually sending it to subscribers.

Are your settings for your unsubscribe url set properly in settings and in the email campaign settings?

Also make sure the domain you want them to navigate to is what is in the site's domain property. For instance, don't have a dev domain and just use an alias as the primary domain. You always want the final domain your visitors will be navigating to in the sites domain property all of the other domains which may be redirected to this primary should all be aliases.

1 votesVote for this answer Unmark Correct answer

Recent Answers


Bruce Williams answered on December 1, 2016 16:30

Hi Brendan::

So, it is not the final url, not technically, but it is the url that is configured as the main site domain, so i dont know why there would be an issue.

I just input http://www.thundertech.com as the source page url and that worked just fine. It is just when we point to a page url of the site we are on that we are having the issue.

So for example: http://test.[example].com/sandbox/interest-dynamic-content

The configured main site domain is: test.[example].com

And the page type for the interest-dynamic-content is Page (menu item) and a portal template i created. Not sure what the issue could be.

0 votesVote for this answer Mark as a Correct answer

Zachary Perry answered on December 1, 2016 16:43

Do you have any security set on the page? I believe the Dynamic Newsletter sends under the public user, so if that user doesn't have access that might be the issue.

0 votesVote for this answer Mark as a Correct answer

Bruce Williams answered on December 1, 2016 16:49

Thanks Brenden and Zach (hope you guys are doing well)::

I didnt have any authentication requirement or anything on it, i could get to page with public user using incognito, so i assume its okay.

This is a bit maddening. If i could see what that validation process/coding is,i think it would help.

0 votesVote for this answer Mark as a Correct answer

Bruce Williams answered on December 1, 2016 17:27

This could be a wild goose chase.

0 votesVote for this answer Mark as a Correct answer

Zachary Perry answered on December 1, 2016 18:31

I am assuming you are just getting the error when clicking the Check page URL availability button.

CMSFormControls/System/URLChecker.ascx.cs is the file you can debug against to see if there is any errors are being thrown in the try catch, since it doesn't log them.

When I test on my local with http://Kentico.com/ I get OK. but if I test on my dev server, I get page not found. This is because our webserver has everything blocked.

You could log into your webserver and make sure you can browse to the page you are trying to get to, could be a setting with the domain not working from that server.

1 votesVote for this answer Mark as a Correct answer

Bruce Williams answered on December 1, 2016 18:34

Thanks Zach::

So, on a local IIS, one of our devs got it working fine. I think it may be our staging server settings. I found some of these articles that may point to a problem with TLS or something of that sort with the .net framework, etc.

http://stackoverflow.com/questions/22627977/the-underlying-connection-was-closed-an-unexpected-error-occurred-on-a-send-w

0 votesVote for this answer Mark as a Correct answer

Bruce Williams answered on December 1, 2016 19:27

We solved it. It was a bot / request filter our sys admin had on the IIS server used for staging. I wish I could give both of you the answer credit, but perhaps next time we cross paths I buy you beers. Thanks guys.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.