Smart Search Index fails to build - Kentico 10

Richard Lloyd asked on July 20, 2018 12:42

I can't get any smart search index to build. I get the message "New (Rebuild required)" with 0 indexed items. I have followed through with other answered questions and the online documentation which suggested this might be because of permissions on the website folders but this has mode no difference. I have the admin site running in IIS (version 10.0.17134.1) which has an app pool running under NetworkService permissions. This has full control on the admin website. We run the main website separately however but i assume this doesn't matter. For the index I have selected a 'pages crawler' type and this uses the admin IIS domain in the crawler settings. The path for indexing is this '/%' from the root page. No page types were selected. Can anyone help.

Recent Answers


David te Kloese answered on July 20, 2018 13:56

Any errors in the Event Log?

Are there any files created in the folder: CMS\App_Data\CMSModules\SmartSearch\[your index name]\

If there are files present, make sure they are not locked (read only). You could also just remove them all and see if rebuilding helps.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on July 20, 2018 15:13

Where are you hosting this? If locally/internally on a physical computer or VM (which it looks like you are) and not some cloud service like Azure or AWS, then you need to grant the user running the AppPool read/write access to the /App_Data directory.

If running in a cloud service, then make sure you're not storing those files in blob storage or storage off of the website.

Check what David mentions, *Are there any files created in the folder: CMS\App_Data\CMSModules\SmartSearch[your index name]*. If there are then you know it's not permissions.

Lastly, check the scheduled tasks. There are 2 tasks regarding search indexes

  • Optimize search indexes
  • Execute search tasks

Make sure they are enabled.

0 votesVote for this answer Mark as a Correct answer

Peter Mogilnitski answered on July 20, 2018 17:27

It might be permission issue... See if this NetworkService account has access (modify) to CMS\App_Data\CMSModules\SmartSearch\. Technically it should, but just in case...

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.