Smart search filter radio option not keeping value in pagination

Tom Wisneski asked on November 4, 2020 17:47

Question, a on website that has products set either "high to low' or 'low to high' designating power rating (generators). We are using a radio button set in a Smart Search Filter webpart. The values for the radio are set as follows (EngineSizeNumber DESC;;High to Low , EnginSizeNumber;;Low to High). So if the user selects the radio it should display the generators by that power filter. The Smart search filter is set (checked) to filter on "auto postback". The issue comes in the pagination. When going to a link in the pagination, it always resets to the first radio filter option. Then for the second webpart in the page is the Smart Search Results webpart. There is a field for "Search Condition". I was wondering could a marco value be put in that field to carry over the filter option in the pagination? I do not know enough about Kentico filters and any assistance would be much appreciated from the community and MVP's. Thank you!

Correct Answer

Tom Wisneski answered on November 4, 2020 22:00

Brenden, I figured it out. The paging mode in the "Smart search results" webpart's paging mode option was set to Querystring. I changed the paging mode option to "postback". It then matched the "Smart search filter" webpart's option of "filter on auto postback." Now all the paging follows through using the sizing radio button option as selected. Thanks again for the input though. Tom W.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Brenden Kehren answered on November 4, 2020 18:31

Set your pagination to postback vs. URL parameter. By default when you navigate to a different page it won't persist that value, you have to do that in code. Using postback allows that value to persist.

0 votesVote for this answer Mark as a Correct answer

Tom Wisneski answered on November 4, 2020 18:39 (last edited on November 4, 2020 18:40)

Brenden --- appreciate the reply on the question. Okay, so slightly confused as to where to set the pagination postback. In the "Smart Search Filter" webpart the "filter auto postback" checkbox is currently checked. In the second webpart, the "Smart Search results", which has the pagination attribute fields. I do not see a postback option on that webpart. There is the checkbox for "search on each page load" which we have checked. Am looking to the wrong place? Thanks.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.