Smart Search - Capitalization Matters (k8.2)

Deb Apprille asked on May 17, 2017 20:02

I'm using smart search on my site. I recently became aware that if someone searches in ALL CAPS in the search, it returns no results.

https://www.atecorp.com/

I'm using the global setting 'Redirect invalid case URLs to their correct versions' as 'Redirect all requests to lower case URLs'. Does that have something to do with it?

I can't seem to figure out how to make the search case insensitive.

Does anyone have any ideas?

Thanks (as always),

-Deb

Recent Answers


Trevor Fayas answered on May 17, 2017 21:16

That won't have anything to do with the Site Search.

Site Search is Lucene.net based, which normally is case insensitive.

I would take a look at the Smart Seach Settings and verify there was no customization done to the indexer, is it using the default index or is it using a custom one that has some odd logic?

0 votesVote for this answer Mark as a Correct answer

Peter M answered on May 17, 2017 21:21

Go to your index, rebuild it (just in case). After that go to 'Search preview' in this index. Search with capital and lower case. Is there a difference in the results? What is the analyzer type for this index?

0 votesVote for this answer Mark as a Correct answer

Deb Apprille answered on May 17, 2017 21:26 (last edited on May 17, 2017 21:26)

@Trevor

It is using three indexes, all of which (I believe) are default.

First Index:

  • Index type: Pages
  • Analyzer type: Subset

Second Index:

  • Index type: Pages
  • Analyzer type: Standard

Third Index:

  • Index type: Pages
  • Analyzer type: Subset

@Peter

The 'Search Preview' searches are the same, regardless of capitalization. But now that you had me do that, I am realizing the trouble seems to be with the predictive feature.

0 votesVote for this answer Mark as a Correct answer

Peter M answered on May 17, 2017 21:35

If preview is working - the problem must be either in your logic and the way your query Lucene.

P.S. If you are using smart search results web part to search specific fields(field:value) - make sure that you set Search settings\Search options to "Full".

0 votesVote for this answer Mark as a Correct answer

Deb Apprille answered on May 17, 2017 21:37 (last edited on May 17, 2017 23:35)

Thanks, I just noticed it was set to 'Basic' and decided to mess around with that. My dev server is acting up so I have to wait a bit, but I will definitely try that when I can. Thanks for your help (as always).

0 votesVote for this answer Mark as a Correct answer

Deb Apprille answered on May 18, 2017 18:32

Update... I can't get the search to accept capital letters. I rebuilt all three indexes, cleared cache, and restarted the server.

The only thing I can think of is that there is a ton of crazy custom code, and my only guess is that it is interfering with the search.

Very frustrating ... thanks to you both for your help. I'll keep fiddling with it.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.