Scheduling Campaign Email Distribution

Sharon Parry asked on March 18, 2020 19:25

This is a version 9 ultimate application, utilizing Email marketing to distribute various task reminders to members of various roles on a regular basis. Campaign emails will be created in advance and scheduled to be sent at appropriate dates/times throughout the month. The scheduled dates and particularly the times are important.

However, I've found that the email doesn't get generated and sent to the email queue until there is some sort of site activity AFTER the scheduled time.

For example, at 4.50 am I scheduled an email to be sent at 5.05 am. I then navigated around the site, just to be sure there would be activity on the site after I had setup the schedule and before the scheduled time. The status of the email said "Scheduled" with the Send time displaying as 5.05 am. I then waited, without navigating anywhere on the site, until 5.10 am. The email hadn't arrived!

So I check the email status, which is now "Sent" with a Send time of 5.10 am, and the email arrives!

Correct Answer

Brenden Kehren answered on March 18, 2020 19:49

Couple things,

  • Check out the documentation about scheduling task execution, it should help you resolve the problem.
  • Use the scheduling service to send your emails
  • Set your website in IIS or Azure settings to be always on. Then the process will be able to run even if the site isn't being accessed for a period of time.
  • Add this to the web.config to help with task execution <add key="CMSUseAutomaticScheduler" value="true" />
  • Create a service that hits a page on your site every 15 minutes so your site stays "awake".
0 votesVote for this answer Unmark Correct answer

Recent Answers

Sharon Parry answered on March 18, 2020 20:19

Hi Brendan,

Thanks for such a quick response.

I think the "AlwaysRunning" app pool setting in IIS will probably be the way to go. I didn't know about that specific setting. Will run some experiments with that. Otherwise a custom service should definitely work!

Re: the scheduling task execution - yes, that was the first place I looked to try and trouble-shoot and the settings are all correct.

0 votesVote for this answer Mark as a Correct answer

Sharon Parry answered on March 18, 2020 20:52

BEAUTIFUL! Setting app pool as "AlwaysRunning" did the trick!

Thanks Brendan.

1 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.