Page Alias Redirecting to default NodePath even when page alias set to do not redirect.

jason zerr asked on January 24, 2020 16:31

I have read the documentation on the setting page alias page, tried re-saving the alias and cleared application cache still I am getting redirected to default path when I click on link that is going to page alias. Am I missing something from the docs ?

Docs link ->

Recent Answers

jason zerr answered on January 24, 2020 17:46

Sort of fixed it by prefixing the currentCulture to the link but now due to the do not redirect page alias setting, even though url will be updated from en-CA/folder/page to fr-CA/folder/page the page content remains in English.

0 votesVote for this answer Mark as a Correct answer

Trevor Fayas answered on January 26, 2020 19:29

There is an actual Kentico Setting under URLs and SEO that is says "Redirect pages to main extension", what is the value of that? If it's checked, it will redirect to the primary page url, if it is not checked it won't.

Also Alias's have a culture setting, it can apply to all cultures, or a specific one. If you have a specific culture set on the Url Alias, it will go to taht culture always, so you may have an alias of fr-CA/folder/page but if the culture is set to en-US on the Url Alias setting, then it will give the english page.

0 votesVote for this answer Mark as a Correct answer

jason zerr answered on January 26, 2020 20:01

@trevor the setting was set to redirection but I was overriding it with settings within the page Alias setting on the page, but turns out there an error with setting page Alias to all cultures with kentico 10 due to which url was overridden but content did not change. But this was fixed by adding a alias for each language.

Here is the reply that I got from Kentico support about the issue : " Cultures - Page aliases with the Culture set to '(all)' not working correctly On sites that had the 'Combine with default culture' setting disabled, page aliases with the Culture set to '(all)' did not work for pages that were not translated in the site's default culture. "

By the way this was issue was resolved in v11

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.