No results for Smart Search on MVC

Tec T asked on September 6, 2017 07:34

I'm using Kentico 10 and want to provide smart search on the MVC site that I'm working on. So I followed the instructions here. Everything was working on my local computer. But when I deployed it to Azure, I'm not getting any results. I checked the CMS and tried the Search preview for the indexes I made and it was returning results there. I tried rebuiling and optimizing the search indexes as well, but still no results on the MVC site.

Any idea where to look? Is there a setting on the CMS that I might have overlooked? Is this a server setting issue? Any help would be appreciated since I really don't know why it's not working on our production server but working fine on my local computer.

Correct Answer

Tec T answered on October 4, 2017 08:40

Just a heads up that was able to solve this with the help of support. Since I was running on a Cloud Service, support suggested to implement <add key="CMSExternalStorageName" value="azure" /> in the web.config. That solved the problem since it seems like my MVC application wasn't looking into the blob storage for the search indexes.

0 votesVote for this answer Unmark Correct answer

Recent Answers


Michal Samuhel answered on September 6, 2017 11:01

Hi you can look into MVC application app_data folder for index files.Also you can take a look into web farm application for failed web farm tasks. Since preview is working I would say that index is fine, however we use web farm technology to synchronize indexes and "push" them from back end where they can only be build to MVC application against which is the search performed.

I would say that missing index is the cause of your problem.

0 votesVote for this answer Mark as a Correct answer

Tec T answered on September 6, 2017 11:49

Hi Michael,

I checked the Web Farm status and both the CMS and the MVC site are healthy.

Regarding the app_data folder, I remember seeing one at our blob storage under cmsstorage/app_data/cmsmodules/smartsearch though I'm not sure if that's the app_data you're pointing out.

But I also looked into the App_Data folder of the MVC site on my local machine and saw the CMSModules folder not included in the project. Inside it are three folders, CMSInstallation, SmartSearch, and WebFarm, all not included as well. Should I redeploy my project this time including all three folders in the project?

0 votesVote for this answer Mark as a Correct answer

Michal Samuhel answered on September 6, 2017 13:15

You are correct in terms of folder on blob storage and app_data/cmsmodules/smartsearch should contain index files on application back-end similarly same folder should be created in MVC application fter first successful synchronization.

Therefore it looks like web farms are not working correctly. This issue is usually caused also by incorrect license, or maybe due to web farm tasks failing. You can take a look into the event log for licence limitation issues. Also you can take a look at web farm tasks, if there a re any web farm tasks to long in the table, it would suggest, that they are not processed correctly.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.