Missing Column in Transformation

Mike Bilz asked on March 18, 2017 00:55

Hello Kentico Team,

I'm in the process of cleaning up my repeaters by removing unnecessary columns, but I've hit a snag. One of my repeaters won't show the "Selected Item Transformation" for my custom page type, when I limit the columns. Instead it just shows the main transformation again, but limited to the selected item.

Without the columns content filter the repeater works fine, and the "Selected Item Transformation" comes up.

Here are my columns: (custom page type specific columns), NodeAlias, DocumentURLPath, NodeAliasPath

Is there something I'm missing?

The repeater is pulling in a custom page type that does not behave as a page. ("Behaves as Page (menu item) type" is not selected)

Thanks in advance for your help.


Correct Answer

Mike Bilz answered on March 20, 2017 17:22

Well, that's embarrassing. Thank you for your help everyone, but the answer was far more simple.

For some reason, after setting the columns filter, you have to re-select the transformation in order for Kentico to see it.

Everything is working fine now. Thanks again for your help.


0 votesVote for this answer Unmark Correct answer

Recent Answers

Jan Hermann answered on March 18, 2017 12:18

Could you please try to add ClassName or NodeClassID?

1 votesVote for this answer Mark as a Correct answer

Rui Wang answered on March 20, 2017 14:21

Mike, for the repeater which is used for listing and single (selected) views, you will need to include the fields from both transformations, plus those 3 for URL generation.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.