link to attachments not working

Rita Mikusch asked on May 1, 2018 20:37


I successfully attached a PDF to my page, and it seems to have worked. But the link to it isn't working.

I checked the event log, and uploading the attachment generated a "Smart search" error with event code "PROCESSSEARCHTASK". Exception type was a "System.NullReferenceException". Maybe smart search tried to index the attachment after, and couldn't find it, which generated the error?

In the settings, "storage" is currently set to "Database and files system". "Files folder" is empty, ie set to default. And "use site-specific subfolders for custom files folder" is checked off.

Does anybody have any suggestions on what to check to fix this? Thank you!

Recent Answers

Trevor Fayas answered on May 2, 2018 03:26

How are you pulling in the link? Are you using like a rich text editor and using the hyperlink, are you using a transformation and trying to display the pdf link (if the file is a Field of type "File" on the page type)?

What link is being generated that isn't working.

If you can answer some of those we can hopefully help you resolve the issue!

0 votesVote for this answer Mark as a Correct answer

Rita Mikusch answered on May 2, 2018 18:56

Hi Trevor,

I'm using the "hyperlink tool" in the rich text editor.

BUT ... somebody else suggested using the FILE page type for this, instead of attachments. So I'm going to go with that.

Thank you!

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.