Kentico 12 MVC with Azure DevOps Pipelines

Nick Kwiecien asked on July 10, 2019 20:59

Hello,

I’m working on Azure DevOps Pipelines for Kentico 12 MVC and when I release to the Azure App Service and restart the App Service I get an error on the MVC site: "The resource you are looking for has been removed, had its name changed, or is temporarily unavailable". When I clear cache on the site through Kentico’s admin the site comes back up but I’ve tried doing that in code on AppStart with no results.

Here are the steps for my MVC Release: 1. Deploy Azure App Service 2. Restart Azure App Service: MVC site 3. Restart Azure App Service: Admin site

I've also tried swapping steps 2 and 3 with no luck.

Any help is greatly appreciated.

Thanks,

Nick

Recent Answers


Sean Wright answered on July 11, 2019 16:02

We have CI/CD configured for our K12 MVC site (both CM and CD) and haven't run into any issues.

Do you see any issues on the content Delivery app or only with the Management app? Are you using a publish profile for deployment or a build -> zip -> copy?

0 votesVote for this answer Mark as a Correct answer

Nick Kwiecien answered on July 11, 2019 19:46

We are seeing the issue on the content delivery app and we are using the build -> zip -> copy method.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.