Javascript Dialog issue Kentico 13.0.15 ASP.Net Core

Michael John Veloso asked on July 22, 2021 06:30

Hi,

We are using Kentico 13.0.15 ASP.Net Core and we have Multiple Sites inside kentico instance.

We have setup the 4 IIS sites for the Front-End and 1 for the admin (which contains the bindings for the other admin site).

Delete a widget and sections is working fine when we first started.

But now, are having this issue "A different origin subframe tried to create a JavaScript dialog. This is no longer allowed and was blocked"

We tried adding add the Response Header Content-Security-Policy: frame-ancestors 'self' http://*.development.com

But to no avail.

But was in clicking on the settings of the widget and section it seems to be working fine. Only the Delete functionality is affected.

Is there any fixed or hotfix on this?

Correct Answer

Zoltán Jalsovszky answered on July 30, 2021 14:21

Hi all,

There are now hotfixes available for both Kentico 12 and Xperience 13, which can be downloaded from DevNet: https://devnet.kentico.com/download/hotfixes

0 votesVote for this answer Unmark Correct answer

Recent Answers


Brenden Kehren answered on July 22, 2021 06:56

Seems like you may not have each sites domain or editing domain or alias set up or configured properly OR have the proper bindings in IIS with SSL setup. While it may have worked before, even a slight change can cause major issues. Check all your sites domains in Kentico and in IIS.

1 votesVote for this answer Mark as a Correct answer

Michael John Veloso answered on July 22, 2021 08:20

Hi Brenden,

I have checked both the CMS under Sites Application both the Domain Name and the Presentation Url and compare with the bindings in the IIS Sites (both for the presentation and the admins). All are the same.

As for the SSL since this is our dev environment we have not setup the SSL for this.

And I also pretty sure that the settings has not change since I am the one allowed to do the configurations.

Any ideas?

0 votesVote for this answer Mark as a Correct answer

Arjan van Hugten answered on July 27, 2021 10:56 (last edited on July 27, 2021 10:59)

Same issue here, seems like it has something to do with this new chrome feature: https://www.chromestatus.com/feature/5148698084376576

For now you can use other browsers or add the following flag to your chrome shortcut: '--disable-features="SuppressDifferentOriginSubframeJSDialogs"'.

0 votesVote for this answer Mark as a Correct answer

Zoltán Jalsovszky answered on July 27, 2021 10:59

Hi all - we are aware of this issue and working on a fix with high priority. I will link the hotfix here once it's available.

In the meantime, there are 2 workarounds - using another browser, or running Chrome with the following command line parameter: --disable-features="SuppressDifferentOriginSubframeJSDialogs"

0 votesVote for this answer Mark as a Correct answer

Brandon Robertson answered on July 29, 2021 15:20

Hello! We are experiencing the same issue as the original poster and have applied hotfix 37. However this did not fix the issue. Is there another hotfix coming?

0 votesVote for this answer Mark as a Correct answer

Zoltán Jalsovszky answered on July 29, 2021 15:23

Hi Brandon! Hotfix 13.0.37 might not work is the Overwrite all files option was not selected during the hotfix installation. There will be another fix released tomorrow where this won't be needed - that's why I didn't post anything about the fix here yet. I recommend waiting for hotfix 13.0.38.

0 votesVote for this answer Mark as a Correct answer

Nelson Nebre answered on July 30, 2021 05:27

Hi Zoltan, do we have hotfix also for K12 version? We also encountering this in our K12 CMS.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.