HTTPS works, 403 - Forbidden: Access is denied for HTTP

Ashutosh Pandey asked on August 6, 2020 09:46

Our websites works with https not with http. https://website-name works fine but when we hit http://website-name, it returns:

Server Error 403 - Forbidden: Access is denied. You do not have permission to view this directory or page using the credentials that you supplied.

We also added rewrite rule in IIS but doesn't work.


Please help

Correct Answer

Ashutosh Pandey answered on August 6, 2020 19:26

Thanks @David, the issue was in SSL Settings, Require SSL was checked. Once unchecked, site works fine now.

0 votesVote for this answer Unmark Correct answer

Recent Answers

David te Kloese answered on August 6, 2020 10:20

Do you have the HTTP URL actually setup in IIS and registered in your application?

IIS needs to know that it should also serve HTTP even though the first thing you do is redirect it.

If you're using the Kentico setting (to use SSL) you also need to configure the site to have HTTP as a domain so the application knows to serve it.

2 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.