How to view Development options in admin

Kayla Johnson asked on October 5, 2017 21:29

A client setup a new Kentico site we will be developing on. However I do not see the options in the menu for CSS, Templates, Content Types, etc. He says we are an admin user and have all permissions. Yet the only thing we can view under the Development category is Email Templates.

https://pasteboard.co/GNz5POAO.png

Recent Answers


David te Kloese answered on October 5, 2017 21:56

Can you verify you're global admin (not just administrator)? Most developer applications are only available for global administrators.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on October 5, 2017 22:27

To see some of those things you need to have the Administrator privilege level assigned to your user as well as at least the CMS Desk Administrator role assigned. It would be best to be assigned the Global Administrator privilege level and Global Administrator role as well but that might not be an option.

0 votesVote for this answer Mark as a Correct answer

Matt Nield answered on October 9, 2017 14:36 (last edited on October 11, 2017 01:01)

Kayla, I'm not sure if you got this fixed. There are two way in which you get various permissions in Kentico. The first is the user privilege level. This has four options:

  • Global Administrator - Full access to all parts of the system for every site. This overrides any other permissions and roles. Only global administrators can use global applications.
  • Administrator - Again, these guys can skip roles and permissions. They can use all non-global applications for the sites that they are assigned to.
  • Editor - Editors can access the administration interface and on-site editing mode for the sites that they are assigned to. They are subject to the assigned roles and permissions.
  • None - These users can access the live site according to their roles and permissions, but cannot access the admin screens.

After user privilege, you have roles and permissions which can be used to grant access to certain parts of your application.

Having read your description, David and Brendan are correct - your user is set-up as an Administrator privilege, which is not sufficient for accessing the development applications that you're looking for. You will need to ask to be elevated to Global Administrator in order to get access.

1 votesVote for this answer Mark as a Correct answer

Kayla Johnson answered on October 12, 2017 22:47

We are an Administrator user but don't see the Development options still...

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on October 12, 2017 22:49

Can you send a screenshot of your users general tab and the roles assigned to that user?

0 votesVote for this answer Mark as a Correct answer

Kayla Johnson answered on October 12, 2017 23:08 (last edited on October 12, 2017 23:09)

https://pasteboard.co/GODLed4.png

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on October 12, 2017 23:11

Ok as I suspected, the Administrator privilege level is NOT a global admin. In fact, this privilege level is pretty restrictive and cannot do or have access to a lot of things a global admin can have access to.

If this person is an admin, I'd add them to the "CMS Desk admin" role in addition to having the Administrator privilege level.

0 votesVote for this answer Mark as a Correct answer

Matt Nield answered on October 13, 2017 10:08

Hi Kayla, as per the above and in your screenshot - the privilage that you have is Administrator. What you won't be able to see in the Privilege level setting is an additional option for Global Administrator, which will give you access to things like development tools.

I'd agree with Brenden that you'd probably want to check the roles assigned ot your user, but I do not believe that any of these roles will give you access to global areas of the system such as the development tools. You will need to speak to the client that setup the site and ask them to change this privilege level to Global Administrator in order to progress.

0 votesVote for this answer Mark as a Correct answer

Kayla Johnson answered on October 13, 2017 15:09

It looks like I can add myself to the CMS Desk Admin role. But it's saving. We also received an email from the client that they also added us to the role after I assumed it was because I didn't have permission to give myself a higher role. But we still are not assigned to the CMS Desk user even though the client said they added us. Is there a reason it wouldn't be saving? Also they said we were a Global Admin but I don't see that we are. I don't see it mentioned it anywhere.

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on October 13, 2017 15:17

Here are the instructions to give your client to add you as a global administrator.

  1. First, they need to be a global administrator in order to do this.
  2. On your user account, assign the privilege level of "Global Administrator".
  3. On the roles for your user account, select Global (upper right corner, change from current site) and click Add Role.
  4. Select Global Administrator and click save.

See the video below for the actual process.
https://kehrendev.tinytake.com/sf/MjAyNzM4MF82Mzk1OTY2

1 votesVote for this answer Mark as a Correct answer

Kayla Johnson answered on October 13, 2017 15:27

Where on our profile will it say Global Admin so that we can verify that we are?

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on October 13, 2017 15:28

Watch the screen share I posted in the previous post and you will see where it says Global Admin.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.