External RSS Feed using Data Source and Basic Repeater Not Working

Ben Bricker asked on July 13, 2016 16:09

One of the RSS Feeds on a site we manage has stopped working. We're not sure how long ago it stopped working, but nothing on our end changed. We think maybe the data source has changed a bit, but either way, we have had no luck getting it to work.

This is the error we are getting from Kentico: A column named 'link' already belongs to this DataTable: cannot set a nested table name to the same name.

I've searched for the cause of this error and it seems to have something to do with the XML Reader in C#, which I assume is what is running the Data Source on the back end.

Here is the feed that we are attempting to read from:

But we have also tried the feed that is provided by Kentico on this page, but that one is throwing the same error.

I was wondering if anyone had any luck with fixing this error, or if there was a hot fix for it?


Correct Answer

emma zelewsky answered on July 15, 2016 16:10

If you haven't already, take a look at the r42 RSS reader webpart, which takes the place of a data source and repeater combo. We've had good luck with it in earlier versions of Kentico, as well as v.8.2.

Good luck!

0 votesVote for this answer Unmark Correct answer

Recent Answers

Brenden Kehren answered on July 13, 2016 16:54

It appears you may need to set the location of your items in your DataSource. The \channel\description node contains a \link node so I could see where it might be getting confused. You might show the properties of your datasource or see if it is set to \channel vs. \channel\item.

0 votesVote for this answer Mark as a Correct answer

Ben Bricker answered on July 13, 2016 17:44

I've tried specifying the table name, but I very well may be doing that wrong. Here are the properties for the data source web part:

XML URL: http://rss.medicalnewstoday.com/seniors-aging.xml

XML custom XSD schema URL:

Table name: \channel\item

ORDER BY expression:

Select Top N items:

WHERE condition:

Filter name:

0 votesVote for this answer Mark as a Correct answer

emma zelewsky answered on July 13, 2016 23:28

This config works in v.8.2--

RSS data source webpart:

Web part control ID: RSSDataSource_med
RSS feed URL: http://rss.medicalnewstoday.com/seniors-aging.xml
Top N: 10
(all other settings are default)

Basic repeater webpart:

Data source name: RSSDataSource_med
Transformation name: CMS.RSSTransformations.rss_dev01_med
No record found text: No data found - no med
(all other settings are default)


<p><a href="<%# Eval("link") %>"><%# Eval("title") %></a><br />
&mdash;<%# Eval("pubDate") %>&mdash;<%# Eval("guid") %></p>

Interestingly, it does not work with the Atom Data Source Webpart, though the feed points to the Atom namespace. I saw a similar error: Cannot add a nested relation or an element column to a table containing a SimpleContent column.

Hope that helps!

1 votesVote for this answer Mark as a Correct answer

Ben Bricker answered on July 14, 2016 16:26

I just tested this setup in one of our v8.2 sites and it works. Unfortunately it's still not working on the v6.0 site that we need it to work on. Looks like we'll either need to update or apply a hot fix.

Thanks for your help though!

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.