Disable reindexing?

Max De Los Reyes asked on January 21, 2023 00:00

Hello. I am trying to fix a problem with my Smart Search settings, but every time I open the application and begin editing a custom index, the application undergoes an entire, hours-long reindexing process of every product on our site. Is there any way to temporarily disable the reindexing process? I've tried disabling the Scheduled Task, and disabling the "Enable smart search indexing" option in Settings>System>Search. This is not on production.

I also don't know if "reindex" is the right term. All I know is that in the Event Logs, I can see that the application is continually checking out, updating, and checking back in/publishing our product pages until it's made its way through all of them.

This is also related to my [previous question](https://devnet.kentico.com/questions/index-provider-class, if anyone has any insight there. Thank you.

Correct Answer

Juraj Ondrus answered on January 23, 2023 07:16

What is the code of your custom index? If you check the blue info boxes in the documentation on this topic, to update the content of the custom index the rebuilding is required. The scheduled tasks and settings are not applied in this case of custom index. I would recommend reviewing your code and maybe optimize it.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Max De Los Reyes answered on February 7, 2023 18:38

Hi Juraj, I resolved the issue of these two questions a while ago but forgot to mark you correct. It was the lengthy code example from that documentation you linked that tipped me off to my issue. Thanks.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.