Configuring Azure storage instructions not working

Mark McDonald asked on July 30, 2021 12:02

I'm following the steps here:

I've created the class library shared referenced by both the CMS and MVC applications with the initialization module, and dropped in the storage details in the web config.

I run the CMS and site in IIS Express and nothing. Media continues to be file based as before. I set I debugger in the module OnInit but it never gets hit - so I'm guessing the module is never loaded. And I certainly don't see anything in the Azure storage.

There don't seem to be any log files or anything in the event viewer. I've tried to apply the same instructions to a freshly spun up DancingGoat site and still nothing, and no indication as to what is not working. Anyone got any suggestions?

Correct Answer

Mark McDonald answered on July 30, 2021 12:25

Looks like I missed a custom Kentico [assembly: AssemblyDiscoverable] attribute in the class library. I'd just referenced the assembly instead.

0 votesVote for this answer Unmark Correct answer

   Please, sign in to be able to submit a new answer.