Configuring authorize.net test data - Unable to finish payment: Payment gateway connection failed.

jeff McDaniel asked on May 3, 2017 19:32

Hi all,

I have authorize.net set up to accept test payment methods using Kentico's build in e-commerce checkout process. I have a sandbox account set up in authorize.net and have my test credentials loaded in Kentico.

My problem comes when trying to submit a payment through authorize.net. I get an error I haven't yet found any information for

Unable to finish payment: Payment gateway connection failed.

This only happens when I use the authorize.net test url: https://test.authorize.net/gateway/transact.dll. No matter what I put in as the transaction API login, this error always occurs. I could put my real transaction login, or I could just put testtesttesttest and the same error will occur each time. I see the same exact error if I set the payment gateway to https://blahblahblah.com or devnet.kentico.com. It will always occur without fail.

If I set the url to https://secure2.authorize.net/gateway/transact.dll, at least I get an error back from authorize.net saying that the user ID is invalid (which makes sense since they are sandbox credentials). That is the only URL I've been able to see this on.

Has any one ever seen this error before when setting up authorize.net sandbox mode for Kentico? How were you able to get around it? My question on approaching this problem is two parts.

  1. How would I be able to verify that Kentico is sending my data through to the correct place? I've used chrome's developer network tools to analyse the get/posts that are being sent and I see that kentico is getting a post and has a code of 200, which says it is sending through, but I don't see any URL that it is sending to or that it is receiving anything.

  2. Can we use Kentico to get an actual error code number from authorize.net? If the transactions are actually being sent through and coming back as invalid an error code could go a long way towards helping me fix this issue and I can't see any response.

In the meantime I will keep searching to see what I find.

Thanks,

Jeff

Correct Answer

jeff McDaniel answered on May 3, 2017 20:56

Hi everyone.

This has been fixed. I assume many of you will see this soon using authorize.net sandbox account. This is a generic error that could be anything, but in my case it was that fact that Kentico was using TLS version 1.1. A few days ago, authorize.net banned the use of TLS 1.1, so this error was authorize.net refusing the connection.

This accouncement comes from here, and Kentico will be affected for those of you who use .NET 4.5.2 or .NET 4.5

https://community.developer.authorize.net/t5/News-and-Announcements/TLS-1-0-and-1-1-will-be-Disabled-in-Sandbox-on-April-30-2017/m-p/57727#M195

In order to solve this, please follow these instructions and make sure to only allow TLS 1.2

https://devnet.kentico.com/articles/tls-1-2-support

Jeff

1 votesVote for this answer Unmark Correct answer

Recent Answers


Brenden Kehren answered on May 3, 2017 20:00

In the Kentico settings for Authorize.NET have you checked the test box below the settings? This will allow you to enter in testing CC number and data. In the past, I've used the production setup in "test" mode and it works very. Haven't started using the sandbox until recently although it seems to work without issue like the other production environment.

0 votesVote for this answer Mark as a Correct answer

jeff McDaniel answered on May 3, 2017 20:23

Hey Brenden,

Thanks for the reponse - yes I have test mode checked. The transactions I make towards the production mode come back saying TEST MODE.

I'll keep checking and let you know if I can find something else.

Jeff

0 votesVote for this answer Mark as a Correct answer

jenn singh answered on November 15, 2017 20:46

This way has been always useful for me when we want the instagram account hack online to generate the password online for any account that we want to generate the password for.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.