Can't Get Past Login Page

Sharon Parry asked on January 12, 2016 21:50

This site is quite old, not developed by me, .net 4.0, portal templates. Current hosting company has contacted me to try and trouble-shoot a problem they're having, and it's something I've never run into in my 10+ years of developing and hosting Kentico sites.

The site files and database were moved from the original server (which apparently "died") to a new server a few weeks ago. The public facing site is running fine, and doesn't appear to have any errors. However, if you try to access CMSDesk by logging in via the login page (ie, http://[domain]/CMSPages/logon.aspx?ReturnUrl=%2fcmsdesk%2f) you can't get past the login screen after submitting valid username/password. The blank login form is just presented again.

I don't have direct access to the database to query CMS_EventLog, but I've asked the dba to query most recent records, and he tells me it is recording successful authentication, and no error. So I've tried going directly to http://[domain]/cmsdesk (and also tried http://[domain]/cmssitemanager), but I'm just presented with the blank login form at http://[domain]/CMSPages/logon.aspx?ReturnUrl=%2fcmsdesk%2f, which indicates to me that authentication didn't succeed.

Anyone else experienced anything like this before?

Recent Answers

Juraj Ondrus answered on January 13, 2016 09:36

Hi Sharon,
What were the URLs settings set in Site Manager. There were some bugs in the past. Are you able to get in by typing /cmsdesk/default.aspx?

I would check the web.config file - are you using extension-less URLs? I would also check the application pool settings - classic vs integrated mode. There were different web.configs for each mode.

0 votesVote for this answer Mark as a Correct answer

Sharon Parry answered on January 13, 2016 09:57

Hi Juraj,

Just tried to navigate directly to /cmsdesk/default.aspx, but no difference.

Site doesn't use extensionless urls.

Can't seem to find the app pool setting via the Plesk control panel so will have to check with the server admin tomorrow.

0 votesVote for this answer Mark as a Correct answer

Sharon Parry answered on January 14, 2016 21:41

Resolved at last! IIS was reporting that the app kept having an error when it was trying to delete old events, but it was still logging new events. Truncating CMS_EventLog solved the problem. Server admin thinks it must have got corrupted when the old server died as it will be the most active table.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.