admin login re-directs to https

Les Girvan asked on May 11, 2021 18:08

Hi Guys,

I have just setup a new dev/testing server and are looking to do some work on one of our live sites, which had SSL for administration UI enabled. I have, for the purpose of the dev server, disabled this in the settings.

When trying to run the project under localhost, the site opens as http, and as I need to add the localhost domain and add a licence, when I select the 'Sites' link, it redirects to https and fails to load.

I have tried just entering http://localhost:1469/admin but it still redirects to the https.

I have also added into the local IIS a binding for https, but his fails also.

As mentioned, I deselected the use SSL for admin and took a copy of the amended DB and restored this for the local db, but it still reverts to https.

I have also set the browser to delete all data, so don't think its a cache issue.

I have looked at the config, but can't see anything that redirects to https, so wondering if you can advise anything I can check further to resolve please.

Regards Les Girvan

Correct Answer

Dmitry Bastron answered on May 12, 2021 11:22

Hi Les,

This kind of redirect could be defined in web.config, please check it and disable if needed.

0 votesVote for this answer Unmark Correct answer

Recent Answers

Jake Kula answered on May 12, 2021 04:28

Hi Les,

Wondering if this is a portal engine site? If so, it might be worth checking the Global.asax.cs file to see if some custom handling has been added - assuming of course this is a site that has had iterations of development done.

0 votesVote for this answer Mark as a Correct answer

Les Girvan answered on May 12, 2021 11:21

Thanks Jake,

Sorry Jake, yes its a v11 portal site.

I have looked at the global.asx.cs file (/app_code/Global.asax.cs), but it looks the same as others I have in demo sites that have not had ssl applied. I have also copied from the dancing goat demo, but still redirects to https?

I have even copied a webconfig file from the demeo site and updates the connection string, but even that still redirects to https?

0 votesVote for this answer Mark as a Correct answer

Les Girvan answered on May 12, 2021 11:45

Hi Dimitry/Jake,

Thanks for that feedback. On checking the config file again, I noticed that the connection string was pointing to the production site. Changing to local db has resolved the problem now thanks, my mistake :(


0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.