Accessibility Validation

Ben Janssen asked on October 31, 2017 20:57

Kentico Version is 8.1

Getting this error when testing any page. "Validation server is busy right now and was unable to respond in time. Please try to validate the code again.‎"

Could this error come from a firewall blocking the validation site? https://achecker.ca/checker/index.php

Correct Answer

Rui Wang answered on November 1, 2017 14:53

Let me put this in as an official answer and please mark it for others to use.

If you are on V8, 8.1, 8.2, 9 of Kentico CMS and tried to use Accessibility validation and getting error "Validation server is busy right now and was unable to respond in time. Please try to validate the code again.‎" This is because achecker.ca switched from http to https only, and you will need to update the validation URL in one line of the CMS code.

In \CMS\CMSAdminControls\Validation\AccessibilityValidator.ascx.cs find this line

private const string DEFAULT_VALIDATOR_URL = "http://achecker.ca/checker/index.php";

Change http to https, and it should work.

1 votesVote for this answer Unmark Correct answer

Recent Answers


Rui Wang answered on October 31, 2017 21:13 (last edited on November 1, 2017 14:55)

That's likely. What you can do is click on the View source in Kentico, copy and paste the HTML into https://achecker.ca/checker/index.php > Paste HTML markup tab and do the validation that way. It's manual process but you will get the same results.

Be sure to choose the right option for the standard.

1 votesVote for this answer Mark as a Correct answer

James Louis answered on November 1, 2017 08:49

Web creators may care about the honesty of our code, Do my Assignment virtually all customers don't care as extended as the page loads rapidly and looks good.

0 votesVote for this answer Mark as a Correct answer

Ben Janssen answered on November 1, 2017 14:30

Thanks Rui. That does work when I put either the URI or the Source code into the site manually. Unfortunately, in my case, I need to be able to use the module in the Kentico site.

0 votesVote for this answer Mark as a Correct answer

Rui Wang answered on November 1, 2017 14:45 (last edited on November 1, 2017 14:50)

Ben, achecker website changed from http to https only, so you will need to make a change in v8.1 manually as it's only a hotfix for 10.0.14. In \CMS\CMSAdminControls\Validation\AccessibilityValidator.ascx.cs find this line

private const string DEFAULT_VALIDATOR_URL = "http://achecker.ca/checker/index.php";

Change http to https, and it should work.

0 votesVote for this answer Mark as a Correct answer

Ben Janssen answered on November 1, 2017 15:01

That worked. Thanks Rui.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.