503 Error at admin page

Brijesh Singh asked on October 20, 2017 22:08

Hi,

I am trying to start my application locally and able to launch application but at admin console it is throwing 503 error. I installed the demo version and was not able to start the same too. Looks like i am missing something. http://localhost:54391/Admin/CMSAdministration.aspx

Any pointer would be highly appreciated

HTTP Error 503.0 - Service Unavailable The service is unavailable. Most likely causes: An invalid identity in the application pool could cause this error. The application pool is no longer running because of configuration or reaching application failure limits. The concurrent application request limit was reached. Things you can try: Check the event logs and the HTTP error logs for more information. Detailed Error Information: Module    ManagedPipelineHandler Notification    ExecuteRequestHandler Handler    PageHandlerFactory-Integrated-4.0 Error Code    0x00000000 Requested URL    http://localhost:54391/CMSMessages/invalidwebsite.aspx Physical Path    C:\inetpub\wwwroot\kentico8\CMS\CMSMessages\invalidwebsite.aspx Logon Method    Forms Logon User    bksingh Request Tracing Directory    C:\Users\bksingh\Documents\IISExpress\TraceLogFiles\CMS thanks.

Recent Answers


Brenden Kehren answered on October 20, 2017 23:37

Few things:

  • Make sure you're running v4.0 .NET CLR
  • Make sure the user running the application pool has permissions to access the path on your hard drive.
  • Make sure you don't have any compilation errors by building the site first
0 votesVote for this answer Mark as a Correct answer

Brijesh Singh answered on October 23, 2017 17:38

I don't see any issue with these points as I performed all your suggested points. One think I Noticed, the application is calling application dashboard link but I could also see on page load it is validating license. Is it the reason for this error.

Just wanted to add one point: We are connecting stage database from local for debug purpose.

http://localhost:54391/CMSModules/ApplicationDashboard/ApplicationDashboard.aspx

LicenseValidationEnum licenseCheck = LicenseHelper.ValidateLicenseForDomain(RequestContext.CurrentDomain); if (licenseCheck != LicenseValidationEnum.Valid) { URLHelper.ResponseRedirect(URLHelper.ResolveUrl("~/CMSMessages/invalidlicensekey.aspx")); }

Page Info:

Request URL:http://localhost:54391/CMSModules/ApplicationDashboard/ApplicationDashboard.aspx Request Method:GET Status Code:302 Found Remote Address:[::1]:54391 Referrer Policy:no-referrer-when-downgrade Response Headers view source Access-Control-Allow-Credentials:true Access-Control-Allow-Headers:Origin, X-Requested-With, Content-Type, Accept Access-Control-Allow-Methods:POST,GET,OPTIONS,PUT,DELETE Access-Control-Allow-Origin:http://www.technologyselection.net Cache-Control:private Content-Type:text/html; charset=utf-8 Date:Mon, 23 Oct 2017 15:35:39 GMT Location:/CMSMessages/invalidwebsite.aspx Server:Microsoft-IIS/10.0 Transfer-Encoding:chunked X-AspNet-Version:4.0.30319 X-SourceFiles:=?UTF-8?B?QzpcaW5ldHB1Ylx3d3dyb290XGtlbnRpY284XENNU1xDTVNNb2R1bGVzXEFwcGxpY2F0aW9uRGFzaGJvYXJkXEFwcGxpY2F0aW9uRGFzaGJvYXJkLmFzcHg=?= Request Headers view source Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,/;q=0.8 Accept-Encoding:gzip, deflate, br Accept-Language:en-US,en;q=0.9 Connection:keep-alive Cookie:ASP.NET_SessionId=ovf2snlziheu144btwhfvozw; CMSCookieLevel=1000; CMSPreferredCulture=en-US; AUTHTECNEW=5CFD8A6FE553A7CC0B3952B065496823A95F9C259C0208CC058AF7D8D4A655B698C289CAA79A6CB8FF77568AD549D144EB82751823276BF2483B9B4E821892D83E8A8EACF96AD5122745FE55B3707EEF7D43A40A3C7ECA753D626B483840F058EFDE4B50D062E7C1190896C50CED165108C09789; CMSPreferredUICulture=en-us Host:localhost:54391 Referer:http://localhost:54391/Admin/CMSAdministration.aspx Upgrade-Insecure-Requests:1 User-Agent:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.62 Safari/537.36

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.