Weird result in Kentico Smart Search

Yowaraj Chhetri asked on July 12, 2019 04:10

Hi,

Kentico 10 smart search is giving me weird result. I have indexed cms.file. Analyser type is "Starts with", index type is "page". I created a document file (.xlsx) named "abc" and it has got a content "def ghi", no metadata and tags. When i am searching for keyword "child", search result displays pages with "child" content plus above mentioned document file as well. There is no mention of "child" on that document file in any ways. The problem is coming for search mode (All words, Any words). This is not always the case for all other content, but for some content it gives me wired result.

If anyone got similar problem or can someone assist me please. Thank you

Recent Answers


Roman Hutnyk answered on July 12, 2019 16:42

Are you sure that mentioned index returns that result? I believe search result my use multiple indexes. Is there tokenization configured for any field? - this one might be tricky enough

Also search mechanism is quite complex, has a lot of variables in multiple configuration and sometimes it is a bit complex to get what you really need - you have to play a bit with it :)

0 votesVote for this answer Mark as a Correct answer

Yowaraj Chhetri answered on July 15, 2019 08:20

Hi Roman,

Thank you for the response.

Yes, search configuration are all correct and I did not tokenize any fields for cms.file page types. I did copy all the content from abc.xlsx to xyz.xlsx file and tried the smart search again. This time when I search from "Child" it did not show the xyz file but again showed abc file, which is very weird. There is no difference in abc and xyz file, except abc was created a very long time back (6 months old).

I am really surprised what could be the problem.

Thanks in advanced.

0 votesVote for this answer Mark as a Correct answer

Dragoljub Ilic answered on July 15, 2019 16:28

Hi Yowaraj,

Did you tried to clean attachments search cache? Maybe something is messed up in indexed content of attachments in DB and because of that you are getting the old results? You can achieve that by going to: System -> Files -> Attachments tab and click on 'Clear attachment search cache' at the top on the page.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.