Unable to build search index

Roman Hutnyk asked on September 18, 2015 15:11

Hi everyone!

I have an issue with building search index. I'm running Kentico 8 on Azure as a cloud service. Have CMSApp and SearchWorker roles there, both are running fine according to Azure portal. No web farm.

I was able to build index with simple analyzer type, but no luck with subset. What happens is system attempts to build index, size of the index changes all the time while it is building, but it never stops. Looks like it attempts, fails, attempts again and so on. Also rebuild task never disappears from search tasks list.

I've already tried to remove all search indexes with their files, redeploy app, restart search worker role - this lasts for a couple of days already. :(

Did anyone had similar issue? Any ideas?

Recent Answers

Bryan Soltis answered on September 18, 2015 17:07

Hi Roman,

I have seen issues like that with Smart Search. I can't say I know of an exact fix, however, these are the tings I normally try. I know you have done some of these but there may be some you haven't tried.

  • Confirm that you did not include any SmartSearch index files in the deployment package
  • Reboot the web and worker roles
  • Reimage the web and worker roles
  • RDP to the worker roles. Delete any files in the C:\Resources[Some GUID]\CMSTemp and CMSCache folders. (I may have the exact path) on the WEb and Worker roles.
  • Delete the physical files from Azure Storage
  • Create a new index and try and create it
  • Update the web.config with bigger timeout values for Smart Search Lock and Timeout values (https://docs.kentico.com/display/K8/Reference+-+Web.config+application+keys#Reference-Web.configapplicationkeys-Smartsearchsettings)

I often will try one of the above and then reboot / reimage the servers. I find that re-imaging reset them and cleans up a lot of stuff, unless your deployment package has the index files in them. If that is the case, you will have to rebuild / redploy without any SS index files included.

2 votesVote for this answer Mark as a Correct answer

Roman Hutnyk answered on September 19, 2015 20:50

Bryan, thanks a lot for your recommendation. I've tried some of them earlier, like you said, and tried others now, unfortunately with no luck. This instance drives me crazy for last week and I feel like beginner, that has no clue what's going on. ((

0 votesVote for this answer Mark as a Correct answer

Srikanth N answered on October 25, 2017 11:22

Hi, I'm also experiencing the same issue. I'm able to update the search index, but rebuild always going to task tab and it is staying there for a long time. Even Process tasks also not working.

The same thing is working fine in QA Environment. We have the same code base across QA, Stage and Prod. By the way our clients are using Amazon storage for saving index files. So the indexes are not available at "App_Data/cms_Modules/Smartsearch/".

Any suggestions?


0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.