Tracking Email Campaigns - "View tracking statistics" not appearing in the actions menu

Sarah Pengelly asked on June 19, 2015 19:34

I am setting up email campaigns in a Kentico 8.2 site for a client. The system is hotfixed to 8.2.7. They have an ultimate license.

When I send out emails with links it them, click on the links, then return to Kentico to try to view the tracking statistics I don't see this option in the actions menu.

I am able to see sent emails, opened emails, bounced emails properly.

Any idea as to why the "View tracking statistics" isn't showing up in the actions menu?

Recent Answers

Daniela Kubikova answered on June 25, 2015 15:13

Hi Sarah,

I also have 8.2.7 with the Ultimate license installed and everything works properly. So I have only these two ideas:

  1. The tracking of clicked links is not enabled for your E-mail campaign. Edit your e-mail campaign, go to Configuration tab and ensure that the 'Track clicked links' box is checked.

  2. You have sent only draft e-mail, using the 'Send draft' button on the Content tab. These e-mails are not tracked.

When the tracking is enabled and new e-mail campaign containing working links is sent to any subscriber, new icon should appear in the Actions column (right next to the 'Delete' icon) which opens the link tracking statistics dialog.

Regards, Daniela

0 votesVote for this answer Mark as a Correct answer

Sarah Pengelly answered on June 25, 2015 15:26

Hi Daniela,

Thanks for responding. After some back and forth with support, I figured out what the problem was. I had a base URL defined as a macro. When you have a macro in this field and create links from the site tree, the tracking statistics will not work. The solution is either to have no value in the base URL configuration or hardcode it if your use case is a different URL to the Kentico install.

Kentico support said they would not be fixing this behaviour. I think they should at least update the documentation to alert users of this use case. I still think it is a bug albeit with a work around.


0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.